diff mbox series

[bug#54457,PATCHv3,2/9] gnu: Add libnetfilter-cttimeout

Message ID 738bfc99-1a5e-831f-8b33-6a39585017bb@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

fesoj000 March 26, 2022, 11:34 p.m. UTC
* gnu/packages/linux.scm (libnetfilter-cttimeout): New variable.
---
  gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
  1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3f7118dadc..4e9d8867dd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7306,6 +7306,34 @@  (define-public libnetfilter-conntrack
     (supported-systems (filter target-linux? %supported-systems))
     (license license:gpl2+)))
  
+(define-public libnetfilter-cttimeout
+  (package
+   (name "libnetfilter-cttimeout")
+   (version "1.0.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/"
+                         "libnetfilter_cttimeout/files/"
+                         "libnetfilter_cttimeout-"
+                         version ".tar.bz2"))
+     (sha256
+      (base32
+       "1fpyz1zlvcq80244knvyvy87909xjqlj02lmw8yblz2m9xsi5axf"))))
+   (build-system gnu-build-system)
+   (native-inputs (list pkg-config))
+   (inputs (list libmnl))
+   (synopsis "Library for kernel connection tracking timeout infrastructure")
+   (description "libnetfilter_cttimeout is the userspace library that provides
+the programming interface to the fine-grain connection tracking timeout
+infrastructure. With this library, you can create, update and delete timeout
+policies that can be attached to traffic flows. This library is used by
+conntrack-tools.")
+   (home-page (string-append
+               "https://netfilter.org/projects/libnetfilter_cttimeout/index.html"))
+   (supported-systems (filter target-linux? %supported-systems))
+   (license license:gpl2)))
+
  (define-public proot
    (package
      (name "proot")