diff mbox series

[bug#65778] gnu: makefile2graph: fix cross-compile.

Message ID 73861664e7cb3ca637a05ff57702f1f7f6a2a371.1693995953.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#65778] gnu: makefile2graph: fix cross-compile. | expand

Commit Message

Z572 Sept. 6, 2023, 10:25 a.m. UTC
* gnu/packages/code.scm (makefile2graph): fix cross-compile.
[arguments]: Use gexp and CC-FOR-TARGET.
---
 gnu/packages/code.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)


base-commit: 6113e0529d61df7425f64e30a6bf77f7cfdfe5a5

Comments

Ludovic Courtès Sept. 14, 2023, 8:58 p.m. UTC | #1
Zheng Junjie <zhengjunjie@iscas.ac.cn> skribis:

> * gnu/packages/code.scm (makefile2graph): fix cross-compile.
> [arguments]: Use gexp and CC-FOR-TARGET.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 9cdda2b751..3e91392ef8 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2021 lu hui <luhuins@163.com>
 ;;; Copyright © 2021, 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -769,11 +770,13 @@  (define-public makefile2graph
         (base32 "1gjfk3d8qg3cla7qd2y7r9s03whlfwy83q8k76xfcnqrjjfavdgk"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:test-target "test"
-       #:make-flags (list "CC=gcc" (string-append "prefix=" %output))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     (list
+      #:test-target "test"
+      #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                           (string-append "prefix=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))))
     (native-inputs
      (list graphviz))
     (home-page "https://github.com/lindenb/makefile2graph")