diff mbox series

[bug#72355,1/2] gnu: Add python-httpauth.

Message ID 735b406e5a290ef59c02282a46d64805c63bd666.1722275874.git.jgart@dismail.de
State New
Headers show
Series [bug#72355,1/2] gnu: Add python-httpauth. | expand

Commit Message

jgart July 29, 2024, 5:58 p.m. UTC
* gnu/packages/python-web.scm (python-httpauth): New variable.

Change-Id: I02ece90600961a634d30f34c301bd387e5aa23b7
---
 gnu/packages/python-web.scm | 20 +++++++++++++++++++-
 1 file changed, 19 insertions(+), 1 deletion(-)


base-commit: fdc6274de5b1d617fcabb3f3af9d2c0dd2a6520d
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 94a0406ea7..5bc57fe0e5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -45,7 +45,7 @@ 
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
 ;;; Copyright © 2021, 2022, 2024 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2022, 2024 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -831,6 +831,24 @@  (define-public python-a2wsgi
 way around.  It depends only on the Python standard library.")
     (license license:asl2.0)))
 
+(define-public python-httpauth
+  (package
+    (name "python-httpauth")
+    (version "0.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "httpauth" version))
+              (sha256
+               (base32
+                "1m6rwvivg61l3h34hf6p6gkqmr69sb1c4k5ha379nxq0p8bfgahb"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/jonashaag/httpauth")
+    (synopsis "WSGI HTTP Digest Authentication middleware")
+    (description "@code{python-httpauth} is WSGI middleware that secures some/all
+routes using HTTP Digest Authentication.")
+    (license license:bsd-2)))
+
 (define-public python-css-html-js-minify
   (package
     (name "python-css-html-js-minify")