diff mbox series

[bug#59800,1/5] gnu: openscenegraph: Use modern package style.

Message ID 7324733de60f8653c1b364c7825e69ec21cba00a.camel@gmail.com
State New
Headers show
Series Add esmini | expand

Commit Message

Liliana Marie Prikler Dec. 3, 2022, 8:12 a.m. UTC
* gnu/packages/graphics.scm (openscenegraph)[arguments]: Convert to list
of G-Expressions.
---
 gnu/packages/graphics.scm | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 60c6a979c5..4193c2949b 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1292,14 +1292,15 @@  (define-public openscenegraph
      `((upstream-name . "OpenSceneGraph")))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f                      ; no test target available
-       ;; Without this flag, 'rd' will be added to the name of the
-       ;; library binaries and break linking with other programs.
-       #:build-type "Release"
-       #:configure-flags
-       (list (string-append "-DCMAKE_INSTALL_RPATH="
-                            (assoc-ref %outputs "out") "/lib:"
-                            (assoc-ref %outputs "out") "/lib64"))))
+     (list
+      #:tests? #f                      ; no test target available
+      ;; Without this flag, 'rd' will be added to the name of the
+      ;; library binaries and break linking with other programs.
+      #:build-type "Release"
+      #:configure-flags
+      #~(list (string-append "-DCMAKE_INSTALL_RPATH="
+                             #$output "/lib:"
+                             #$output "/lib64"))))
     (native-inputs
      (list pkg-config unzip))
     (inputs