diff mbox series

[bug#74113] gnu: Add r-robustrankaggreg.

Message ID 7323ea34119361e3ea82af491a11e5b845667082.1730311725.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#74113] gnu: Add r-robustrankaggreg. | expand

Commit Message

Navid Afkhami Oct. 30, 2024, 6:08 p.m. UTC
* gnu/packages/cran.scm (r-robustrankaggreg): New variable.

Change-Id: I2dbc983544b9858e279c192f00d52b3f18bc71c4
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: d6f775c30c6f47e174f6110d1089edc6315600e4
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 717e4eac89..e5e1d25c77 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1629,6 +1629,28 @@  (define-public r-pma
 canonical correlation analysis.")
     (license license:gpl2+)))
 
+(define-public r-robustrankaggreg
+  (package
+    (name "r-robustrankaggreg")
+    (version "1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RobustRankAggreg" version))
+       (sha256
+        (base32 "0p2nbgxv2132gcyx7zq2gzl6ipsxndx64i7y8v9nh5awcdy8v44p"))))
+    (properties `((upstream-name . "RobustRankAggreg")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=RobustRankAggreg")
+    (synopsis "Methods for robust rank aggregation")
+    (description
+     "This tool provides methods for aggregating ranked lists, especially lists of genes.
+It implements the Robust Rank Aggregation and other simple algorithms for the task.
+RRA method uses a probabilistic model for aggregation that is robust to noise and
+also facilitates the calculation of significance probabilities for all the elements
+in the final ranking.")
+    (license license:gpl2)))
+
 (define-public r-rpresto
   (package
     (name "r-rpresto")