[bug#77748] gnu: Add sbcl-stumpwm-tomato.

Message ID 732049c12f55f1042dadcb122a1fe60c1606d88f.1744386106.git.dk@junkeria.club
State New
Headers
Series [bug#77748] gnu: Add sbcl-stumpwm-tomato. |

Commit Message

Junker April 11, 2025, 3:43 p.m. UTC
  * gnu/packages/wm.scm (sbcl-stumpwm-tomato): New variable.

Change-Id: I2cd47ba97f51bcd271bcf80f46f9cfa98cf35240
---
 gnu/packages/wm.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 2934de1447f87b361608ef3a2a756b8a5d2f42e6
  

Comments

Guillaume Le Vaillant April 14, 2025, 12:11 p.m. UTC | #1
Patch applied as 2cddd8b935da12431c72c12a596bc4c0ee93b0f5.
Thanks.
  

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 375ed08c00..36007c1367 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2871,6 +2871,29 @@  (define-public sbcl-stumpwm-binwarp
 mouse control mode for StumpWM.")
     (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
 
+(define-public sbcl-stumpwm-tomato
+  (package
+    (name "sbcl-stumpwm-tomato")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Junker/stumpwm-tomato")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0qq11spvhrcq74gh0dw0p4859ai2mqzbxa45gjbf599kmcybp1pa"))))
+    (arguments
+     '(#:asd-systems '("tomato")
+       #:tests? #f))
+    (build-system asdf-build-system/sbcl)
+    (inputs (list stumpwm))
+    (home-page "https://github.com/Junker/stumpwm-tomato")
+    (synopsis "Advanced Pomodoro timer module for StumpWM")
+    (description "Advanced Pomodoro timer module for StumpWM.")
+    (license license:gpl3+)))
+
 (define-public sbcl-stumpwm-ttf-fonts
   (package
     (inherit stumpwm-contrib)