diff mbox series

[bug#48484,2/2] gnu: Remove PostgreSQL 11.

Message ID 72dfebe0d86c5bdd0890a5c88d2081dcbb170cb3.1621279407.git.leo@famulari.name
State New
Headers show
Series [bug#48484,1/2] gnu: Remove PostgreSQL 9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari May 17, 2021, 7:23 p.m. UTC
* gnu/packages/databases.scm (postgresql-11): Remove variable.
(postgresql-10): Inherit from postgresql-13.
---
 gnu/packages/databases.scm | 17 ++---------------
 1 file changed, 2 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 5b6504b5c1..96033bc020 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1098,25 +1098,12 @@  pictures, sounds, or video.")
                 "18dliq7h2l8irffhyyhdmfwx3si515q6gds3cxdjb9n7m17lbn9w"))
               (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))))
 
-(define-public postgresql-11
-  (package
-    (inherit postgresql-13)
-    (name "postgresql")
-    (version "11.12")
-    (source (origin
-              (inherit (package-source postgresql-13))
-              (uri (string-append "https://ftp.postgresql.org/pub/source/v"
-                                  version "/postgresql-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "016bacpmqxc676ipzc1l8zv1jj44mjz7dv7jhqazg3ibdfqxiyc7"))))))
-
 (define-public postgresql-10
   (package
-    (inherit postgresql-11)
+    (inherit postgresql-13)
     (version "10.17")
     (source (origin
-              (inherit (package-source postgresql-11))
+              (inherit (package-source postgresql-13))
               (uri (string-append "https://ftp.postgresql.org/pub/source/v"
                                   version "/postgresql-" version ".tar.bz2"))
               (sha256