diff mbox series

[bug#68060,3/5] gnu: vim-coqtail: Move vim-full to arguments.

Message ID 724bdaab2e29ea106be52177620cd2c5d53d203d.1703690765.git.jean@foundationdevices.com
State New
Headers show
Series gnu: Add neovim-coqtail. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Dec. 27, 2023, 3:31 p.m. UTC
* gnu/packages/vim.scm (vim-coqtail): Move vim-full from native-inputs
  to arguments.

Change-Id: I20cc1e0772727f8fc7db70b42151432fb6349fc7
---
 gnu/packages/vim.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 7fc6cae6e9..e27feb13f7 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -470,7 +470,8 @@  (define-public vim-coqtail
                   "0av2m075n6z05ah9ndrgnp9s16yrz6n2lj0igd9fh3c5k41x5xks"))))
       (build-system vim-build-system)
       (arguments
-       '(#:plugin-name "coqtail"
+       `(#:plugin-name "coqtail"
+         #:vim ,vim-full ; Plugin needs Python 3.
          #:phases
          (modify-phases %standard-phases
            (add-before 'install 'check
@@ -491,9 +492,7 @@  (define-public vim-coqtail
                                       "/share/vim/vimfiles/pack/guix/start/vader")))
                    (with-directory-excursion "tests/vim"
                      (setenv "VADER_PATH" vader-path)
-                     (invoke (string-append
-                               (assoc-ref (or native-inputs inputs) "vim-full")
-                               "/bin/vim")
+                     (invoke "vim"
                              "-E" "-Nu" "vimrc"
                              "-c" "Vader! *.vader")))
 
@@ -501,10 +500,9 @@  (define-public vim-coqtail
                  ;; they don't get installed.
                  (delete-file-recursively "python/__pycache__")))))))
       (native-inputs
-       `(("coq-for-coqtail" ,coq-for-coqtail)
-         ("python-pytest" ,python-pytest)
-         ("vim-full" ,vim-full)         ; Plugin needs Python 3.
-         ("vim-vader" ,vim-vader)))
+       (list coq-for-coqtail
+             python-pytest
+             vim-vader))
       (propagated-inputs (list coq coq-ide-server))
       (synopsis "Interactive Coq proofs in Vim")
       (description "Coqtail enables interactive Coq proof development in Vim