diff mbox series

[bug#55703] Update minetest

Message ID 721968ef33aabe47a37dae8d330a0c2c4a8a7a8c.camel@planete-kraus.eu
State Accepted
Headers show
Series [bug#55703] Update minetest | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vivien Kraus June 5, 2022, 8:36 a.m. UTC
Hello,

Le dimanche 29 mai 2022 à 18:39 +0200, Liliana Marie Prikler a écrit :
> 
> > +    (source
> > +     (origin
> > +       (inherit (package-source irrlicht))
> > +       (method git-fetch)
> > +       (uri (git-reference
> > +             (url "https://github.com/minetest/irrlicht")
> > +             (commit version)))
> > +       (sha256
> > +        (base32
> > +         "1jxk1x0f60n8lrz8a6x62aj2pqg0qnbajsld3lqncvwsfbi0xjx1"))
> > +       (patches '())
> > +       (snippet '(begin #t))))
> Instead of inheriting and blanking patches and snippet, you could
> simply not inherit.
That is simpler, yes.

> 
> > +    (arguments
> > +     `(#:tests? #f))
> As with Irrlicht itself, you should write out "; no check target"
Yes.

> 
> > > > * gnu/packages/minetest.scm (minetest-basic-materials): Update to
> > > > 2022-03-28 (commet 9d55f991…).
> > > > [snippet]: Make sound_api_core a dependency, not a submodule.
> > > Again doing two things at once.  I think it'd be wiser to first do
> > > the updates, then add minetest-sound-core, then add the snippets. 
> > > WDYT?
> > 
> > minetest-sound-core is introduced as a submodule for the
> > basic_materials update.  So the code for it is not present at all. 
> > If
> > I first update basic_materials, then the tests will fail because it
> > can’t find sound_core. Do you mean that I should first try to respect
> > the will of the author and add it as a submodule (I don’t know how to
> > do that) and then take it out as a separate package?
> Hmm, perhaps I was confused by the commit message.  If changes to the
> package are necessary for the bump, it makes sense to do them in the
> same commit as you did, but the wording would imply that it was
> previously a submodule, which perhaps through strange git magic is no
> longer available in the source (because it has been externalized).
I rewrote the comment and linked to the basic_material issue mentioned
by Maxime elsewhere in the thread: 

https://github.com/mt-mods/basic_materials/issues/4
> 
> > > ² As pointed out by Maxime elsewhere in the mailing list,
> > > Minetest packages usually have flaky tags in their forges, so
> > > someone needs to look closer at whether this is going to break in
> > > the future.
> > 
> > Yes. Mesecons was using version numbers and then the latest tag is
> > a
> > date. Given that it’s April 1st, maybe there’s something funny
> > occuring here, but the changes around that day looked reasonable to
> > my untrained eye. However, one thing I didn’t notice at first was
> > the
> > drop of the + in the license. Sorry.
> I'm not sure whether that's the right version to bump to, sorry. 
> According to ContentDB the latest release is
> 27c3c515b49af91c1dbc427f31a820722854eb24, but that's untagged in git;
> I
> suggest either making a git-version and adding an appropriate comment
> or contacting upstream for clarification.
Obviously yes that’s the commit to use.

So now the v3 looks like this. What do you think?

Vivien

Comments

Liliana Marie Prikler June 5, 2022, 10:14 a.m. UTC | #1
Am Sonntag, dem 05.06.2022 um 10:36 +0200 schrieb Vivien Kraus:
> So now the v3 looks like this. What do you think?
I cleaned up the commits a little, verified that all the mods build,
and pushed.

Cheers
diff mbox series

Patch

From e7c18085594f7808ea8ef0359d2e020b21498cf0 Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Sun, 29 May 2022 14:43:28 +0200
Subject: [PATCH v3 9/9] gnu: minetest-advtrains: Update to 2.4.1.

* gnu/packages/minetest.scm (minetest-advtrains): Update to 2.4.1.
---
 gnu/packages/minetest.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 5511e6f640..da6e556f4e 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -721,7 +721,7 @@  (define-public minetest-unified-inventory
 (define-public minetest-advtrains
   (package
     (name "minetest-advtrains")
-    (version "2.3.1")
+    (version "2.4.1")
     (source
      (origin
        (method git-fetch)
@@ -729,7 +729,7 @@  (define-public minetest-advtrains
              (url "https://git.bananach.space/advtrains.git")
              (commit (string-append "release-" version))))
        (sha256
-        (base32 "1ijqlchh269jpvmgmdmdvy3nsnk0bszkvvcqk6vaysvxam695ggw"))
+        (base32 "1q2jj8181pjgsakl28xadv0z4sszq1lb5rpgj070wr0px6mp447p"))
        (file-name (git-file-name name version))))
     (build-system minetest-mod-build-system)
     (home-page "http://advtrains.de/")
-- 
2.36.1