diff mbox series

[bug#74345,3/9] gnu: python-boto3: Update to 1.35.59.

Message ID 7136e206f28f94fda62f2739bd807c6244018567.1731518182.git.rekado@elephly.net
State New
Headers show
Series [bug#74345,1/9] gnu: python-s3transfer: Update to 0.10.3. | expand

Commit Message

Ricardo Wurmus Nov. 13, 2024, 5:16 p.m. UTC
* gnu/packages/python-xyz.scm (python-boto3): Update to 1.35.59.
[build-system]: Use pyproject-build-system.
[arguments]: Use #:test-flags instead of custom build phases.

Change-Id: Iafc22bafbf6ef185c2d9f4907386bd904ebaecbd
---
 gnu/packages/python-xyz.scm | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3be34786be5..67219049ff2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19391,7 +19391,7 @@  (define-public python-botocore
 (define-public python-boto3
   (package
     (name "python-boto3")
-    (version "1.21.35")
+    (version "1.35.59")
     (home-page "https://github.com/boto/boto3")
     (source (origin
               (method git-fetch)
@@ -19399,19 +19399,13 @@  (define-public python-boto3
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1kdyf238rpfldnpzs0rdh3nhjn6hwfym4faskyhzlgzkf1smmbg1"))))
+                "10bdzdaw7qg2m5n5ivb2zzsdl7wgjmz05xyxajd4cmk629ick95m"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'delete-network-tests
-           ;; Deleting integration tests because they are trying to connect to AWS.
-           (lambda _
-             (delete-file-recursively "tests/integration")))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-v")))))))
-    (build-system python-build-system)
+     (list
+      #:test-flags
+      ;; Integration tests are trying to connect to AWS.
+      '(list "--ignore-glob=tests/integration/*")))
     (native-inputs
      (list python-nose python-mock python-pytest))
     (propagated-inputs