@@ -19391,7 +19391,7 @@ (define-public python-botocore
(define-public python-boto3
(package
(name "python-boto3")
- (version "1.21.35")
+ (version "1.35.59")
(home-page "https://github.com/boto/boto3")
(source (origin
(method git-fetch)
@@ -19399,19 +19399,13 @@ (define-public python-boto3
(file-name (git-file-name name version))
(sha256
(base32
- "1kdyf238rpfldnpzs0rdh3nhjn6hwfym4faskyhzlgzkf1smmbg1"))))
+ "10bdzdaw7qg2m5n5ivb2zzsdl7wgjmz05xyxajd4cmk629ick95m"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'delete-network-tests
- ;; Deleting integration tests because they are trying to connect to AWS.
- (lambda _
- (delete-file-recursively "tests/integration")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v")))))))
- (build-system python-build-system)
+ (list
+ #:test-flags
+ ;; Integration tests are trying to connect to AWS.
+ '(list "--ignore-glob=tests/integration/*")))
(native-inputs
(list python-nose python-mock python-pytest))
(propagated-inputs