From 45ae7606289e5382a7b9b9373d5920b9730d97c5 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 8 Jan 2020 09:47:19 -0500
Subject: [PATCH] gnu: Add gnome-color-manager
* gnu/packages/gnome.scm (gnome-color-manager): New variable.
---
gnu/packages/gnome.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
@@ -246,6 +246,62 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-color-manager
+ (package
+ (name "gnome-color-manager")
+ (version "3.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1vpxa2zjz3lkq9ldjg0fl65db9s6b4kcs8nyaqfz3jygma7ifg3w"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("appstream-glib" ,appstream-glib)
+ ("colord-gtk" ,colord-gtk)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("exiv2" ,exiv2)
+ ("glib" ,glib)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("itstool" ,itstool)
+ ("libcanberra" ,libcanberra)
+ ("libexif" ,libexif)
+ ("libtiff" ,libtiff)
+ ("libxrandr" ,libxrandr) ; for tests
+ ("libxtst" ,libxtst)
+ ("libxxf86vm" ,libxxf86vm) ; for tests
+ ("vte" ,vte)
+ ("xorgproto" ,xorgproto) ; for tests
+ ("xorg-server" ,xorg-server-for-tests))) ; for tests
+ (synopsis "Color profile manager for the GNOME desktop")
+ (description "GNOME Color Manager is a session framework that makes
+it easy to manage, install and generate color profiles
+in the GNOME desktop.")
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-color-manager")
+ (license license:gpl2)))
+
(define-public gnome-menus
(package
(name "gnome-menus")
--
2.24.1