diff mbox series

[bug#50164] gnu: Add vim-slime.

Message ID 71090397dd7b3e5d9ea958f6a94ed5160b86390d.1629619900.git.efraim@flashner.co.il
State Accepted
Headers show
Series [bug#50164] gnu: Add vim-slime. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Aug. 22, 2021, 8:12 a.m. UTC
* gnu/packages/vim.scm (vim-slime): New variable.
---
 gnu/packages/vim.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: 9e3b68203cba2b1bd96e524d3ae9dfc3336a72f7
prerequisite-patch-id: 6d97f22be1838726393fa9f3c6fe798b9b9d9318

Comments

Efraim Flashner Sept. 9, 2021, 1:06 p.m. UTC | #1
Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d8b5caa7f1..432562d27a 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1035,3 +1035,35 @@  specification.")
 This package includes commands such as @code{SudoWrite} and @code{SudoEdit} and
 help working on Vim buffers and the files they reference with one command.")
       (license license:vim))))
+
+(define-public vim-slime
+  ;; No tagged releases.
+  (let ((commit "a522fed677e50175f52efc5848cc35209af33216")
+        (revision "1"))
+    (package
+      (name "vim-slime")
+      (version (git-version "0.0.0" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/jpalardy/vim-slime")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32 "0k4b629jn6xlxyjxdl3cgm06v9dmx967rqnslv5m82c9kscwpyh4"))))
+      (build-system copy-build-system)
+      (arguments
+       `(#:install-plan
+         '(("autoload" "share/vim/vimfiles/")
+           ("doc" "share/vim/vimfiles/")
+           ("ftplugin" "share/vim/vimfiles/")
+           ("plugin" "share/vim/vimfiles/"))))
+      (home-page "https://technotales.wordpress.com/2007/10/03/like-slime-for-vim/")
+      (synopsis "Vim plugin to give you some slime")
+      (description "SLIME is an Emacs plugin to turn Emacs into a Lisp IDE.  You
+can type text in a file, send it to a live REPL, and avoid having to reload all
+your code every time you make a change.  @code{Vim-slime} is an attempt at
+getting some of these features into Vim.  It works with any REPL and isn't tied
+to Lisp.")
+      (license license:expat))))