diff mbox series

[bug#67773,1/4] gnu: rust-clap-lex: Add 0.6.

Message ID 707ff8dcdf54d40ea17f71228ce1d935@lyrion.ch
State New
Headers show
Series [bug#67773,1/4] gnu: rust-clap-lex: Add 0.6. | expand

Commit Message

Daniel Ziltener Dec. 11, 2023, 5:36 p.m. UTC
---
 gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Daniel Ziltener Dec. 22, 2023, 2:17 p.m. UTC | #1
user guix
usertag 67773 + reviewed-looks-good
thanks

Guix QA review form submission:


Items marked as checked: Lint warnings, Package builds, Commit messages, 
New package licenses, New package tests, New package synopsis and 
descriptions
Christopher Baines Dec. 22, 2023, 4:18 p.m. UTC | #2
user guix
usertag 67769 - reviewed-looks-good
usertag 67773 - reviewed-looks-good
thanks

Daniel Ziltener via Guix-patches via <guix-patches@gnu.org> writes:

> Guix QA review form submission:
>
>
> Items marked as checked: Lint warnings, Package builds, Commit
> messages, New package licenses, New package tests, New package
> synopsis and descriptions

As it says on the page, this feature is for people other than those
involved in submitting the patches, so I'd expect the email to mark them
as reviewed to come from a separate address.
Efraim Flashner Dec. 26, 2023, 11:43 a.m. UTC | #3
This package was already added in the rust-team branch.  Sorry!
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d42ff60a20..7eae768ab7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -13223,6 +13223,27 @@  (define-public rust-clap-complete-fig-3
 with Clap to generate Fig completion scripts.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-clap-lex-0.6
+  (package
+    (name "rust-clap-lex")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "clap_lex" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1l8bragdvim7mva9flvd159dskn2bdkpl0jqrr41wnjfn8pcfbvh"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
+    (synopsis "Command line parser for Clap")
+    (description
+     "This package provides a parser for command line options.  As opposed
+to a declarative parser, @code{rust-clap-lex} processes arguments as a
+stream of tokens.")
+    ;; The user can choose either license.
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-clap-lex-0.5
   (package
     (name "rust-clap-lex")