diff mbox series

[bug#65425] gnu: Add qogir-icon-theme.

Message ID 700dcc14e4a98bb114fff01013a04dc7ca568828.1692621227.git.hako@ultrarare.space
State New
Headers show
Series [bug#65425] gnu: Add qogir-icon-theme. | expand

Commit Message

Hilton Chain Aug. 21, 2023, 12:36 p.m. UTC
* gnu/packages/gnome-xyz.scm (qogir-icon-theme): New variable.
---
 gnu/packages/gnome-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: 182e8ddfc1e88a6ece7e96e0b9535ad44c3c6da6

Comments

宋文武 Aug. 26, 2023, 3:12 a.m. UTC | #1
Hilton Chain <hako@ultrarare.space> writes:

> * gnu/packages/gnome-xyz.scm (qogir-icon-theme): New variable.

Looks good to me, thanks!
Hilton Chain Aug. 29, 2023, 3:18 p.m. UTC | #2
On Sat, 26 Aug 2023 11:12:20 +0800,
宋文武 wrote:
> 
> Hilton Chain <hako@ultrarare.space> writes:
> 
> > * gnu/packages/gnome-xyz.scm (qogir-icon-theme): New variable.
> 
> Looks good to me, thanks!

Thank you for taking a look!
Pushed as 77843170f0b7f5189892bd650d127f42151fa591.
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a1701aaa77..6ba0ee0092 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -240,6 +240,39 @@  (define-public papirus-icon-theme
 and a few extra features.")
     (license license:gpl3)))
 
+(define-public qogir-icon-theme
+  (package
+    (name "qogir-icon-theme")
+    (version "2023.06.05")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vinceliuice/Qogir-icon-theme")
+                    (commit (string-replace-substring version "." "-"))))
+              (file-name (git-file-name name version))
+              (modules '((guix build utils)))
+              (snippet '(substitute* "install.sh"
+                          (("gtk-update-icon-cache") "true")))
+              (sha256
+               (base32
+                "1kn8b9zdamxbfbs7b9qpx53hmjw2l40sxpjw93axb1dqy81yc8da"))))
+    (build-system copy-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'install
+                 (lambda _
+                   (let* ((dest (string-append #$output "/share/icons"))
+                          (flags (list "--theme" "all"
+                                       "--color" "all"
+                                       "--dest" dest)))
+                     (mkdir-p dest)
+                     (apply invoke "bash" "install.sh" flags)))))))
+    (home-page "https://www.pling.com/p/1296407/")
+    (synopsis "Flat colorful design icon theme")
+    (description "This package provides a flat colorful design icon theme.")
+    (license license:gpl3)))
+
 (define-public flat-remix-icon-theme
   (package
     (name "flat-remix-icon-theme")