diff mbox series

[bug#63545,v2,1/2] gnu: heimdal: Run autoreconf.

Message ID 700bdb497cd0431ea9f3d71516f4168f55882ce4.1685319429.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#63545,v2,1/2] gnu: heimdal: Run autoreconf. | expand

Commit Message

Felix Lechner May 29, 2023, 12:19 a.m. UTC
* gnu/packages/kerberos.scm (heimdal): Run autoreconf.
---
Hi Josselin,

Thanks for your review! I sidestepped your suggestions by continuing
to build from the tarball, and running 'autoreconf.'

Kind regards
Felix

 gnu/packages/kerberos.scm | 21 ++++++++++++---------
 1 file changed, 12 insertions(+), 9 deletions(-)


base-commit: d64d6ea2cf5a1be801be355031fb2cfa5901a92a

Comments

Josselin Poiret June 4, 2023, 9:39 a.m. UTC | #1
Hi Felix,

Felix Lechner <felix.lechner@lease-up.com> writes:

> Hi Josselin,
>
> Thanks for your review! I sidestepped your suggestions by continuing
> to build from the tarball, and running 'autoreconf.'
>
> Kind regards
> Felix

Thanks, pushed as d89247150fe6e97c2fceed8d578fd119a782624d.  I removed
the last sentence of the second commit message, as it was no longer
applicable.

Best,
diff mbox series

Patch

diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index c553f8180a..f06410b8f8 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -183,14 +183,7 @@  (define-public heimdal
                (base32
                 "0f4dblav859p5hn7b2jdj1akw6d8p32as6bj6zym19kghh3s51zx"))
               (patches
-               (search-patches "heimdal-CVE-2022-45142.patch"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (substitute* "configure"
-                    (("User=.*$") "User=Guix\n")
-                    (("Host=.*$") "Host=GNU")
-                    (("Date=.*$") "Date=2022\n"))))))
+               (search-patches "heimdal-CVE-2022-45142.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -223,7 +216,12 @@  (define-public heimdal
        #:phases (modify-phases %standard-phases
                   (add-before 'configure 'pre-configure
                     (lambda* (#:key inputs #:allow-other-keys)
+                      (invoke (search-input-file inputs "bin/autoreconf") "--install" "--force")
                       (substitute* "configure"
+                        ;; Reproducible build date, etc.
+                        (("User=.*$") "User=Guix\n")
+                        (("Host=.*$") "Host=GNU\n")
+                        (("Date=.*$") "Date=2022\n")
                         ;; The e2fsprogs input is included for libcom_err,
                         ;; let's use it even if cross-compiling.
                         (("test \"\\$\\{krb_cv_com_err\\}\" = \"yes\"")
@@ -255,12 +253,17 @@  (define-public heimdal
                           (format #t "#!~a~%exit 1~%" (which "sh")))))))
        ;; Tests fail when run in parallel.
        #:parallel-tests? #f))
-    (native-inputs (list bison
+    (native-inputs (list autoconf
+                         automake
+                         bison
                          e2fsprogs      ;for 'compile_et'
                          flex
+                         libtool
                          texinfo
                          unzip          ;for tests
                          pkg-config
+                         perl
+                         perl-json
                          python))
     (inputs (list readline
                   bash-minimal