diff mbox series

[bug#63038,3/5] gnu: neko: Build with httpd/pinned.

Message ID 70030d3036eb8d9930c7443b840f23a1a8b406c8.1682269908.git.leo@famulari.name
State New
Headers show
Series [bug#63038,1/5] gnu: httpd: Update to 2.4.57 [security fixes]. | expand

Commit Message

Leo Famulari April 23, 2023, 5:11 p.m. UTC
* gnu/packages/haxe.scm (neko)[inputs]: Replace httpd with ...
[native-inputs]: ... httpd/pinned.
[arguments]: Forbid keeping a reference to httpd/pinned.
---
 gnu/packages/haxe.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index dbe8b2c19e..44ba33abd1 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -66,7 +66,8 @@  (define-public neko
         (base32 "1xgw646pghsjjbzd8qlaq17vq96swlrazpivrvyrhdj36vb3sci3"))))
     (build-system cmake-build-system)
     (arguments
-     (list #:phases
+     (list #:disallowed-references (list httpd/pinned)
+           #:phases
            #~(modify-phases %standard-phases
                (add-after 'unpack 'prefix
                  (lambda _
@@ -76,7 +77,6 @@  (define-public neko
     (inputs (list apr
                   apr-util
                   gtk+-2
-                  httpd
                   libgc
                   mbedtls-apache
                   mysql
@@ -84,7 +84,9 @@  (define-public neko
                   pcre
                   sqlite
                   zlib))
-    (native-inputs (list git pkg-config)) ; git for source_archive and applying patch
+    (native-inputs (list httpd/pinned
+                         git ; git for source_archive and applying patch
+                         pkg-config))
     (home-page "https://nekovm.org/")
     (synopsis "High-level dynamically typed programming language and virtual
 machine")