diff mbox series

[bug#46686] 回复: Re: bug#46686: [PATCH] gnu: add libucl

Message ID 6tSVk4Fiug-ZOTbsSW7r2irpw0gLdYAmYwzv20UdrLbGWBXntkODGHfA-mJa92yd9jMwVoVt2OtxiFcsVMKsUYpMzp50FGBXqZ7SYIQmIVc=@protonmail.com
State Accepted
Headers show
Series [bug#46686] 回复: Re: bug#46686: [PATCH] gnu: add libucl | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

qblade March 7, 2021, 3:08 a.m. UTC
Hello, I submitted a new patch, because libucl is currently only used in hikari (I will submit its package definition later) I decided to put it in gnu/packages/wm.scm

hikari's home pager: https://hikari.acmelabs.space/

Comments

Ludovic Courtès March 17, 2021, 9:24 p.m. UTC | #1
Hi,

qblade <qblade@protonmail.com> skribis:

> From f80bb9ea8d4161e351b30b6154d25cbfca8095fd Mon Sep 17 00:00:00 2001
> From: qblade <qblade@protonmail.com>
> Date: Sun, 7 Mar 2021 02:31:07 +0000
> Subject: [PATCH] gnu: add libucl
>
> * gnu/packages/wm.scm (libucl): New variable.

Applied with minor tweaks to the description.

Thanks,
Ludo’.
diff mbox series

Patch

From f80bb9ea8d4161e351b30b6154d25cbfca8095fd Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Sun, 7 Mar 2021 02:31:07 +0000
Subject: [PATCH] gnu: add libucl

* gnu/packages/wm.scm (libucl): New variable.
---
 gnu/packages/wm.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5d2b36f312..90453da1c8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -42,6 +42,7 @@ 
 ;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
 ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2350,3 +2351,31 @@  shows a notification for the user on the screen.")
 for wayland conceptually based on the X11 window manager
 @command{ratpoison}.")
     (license license:expat)))
+
+(define-public libucl
+  (package
+    (name "libucl")
+    (version "0.8.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vstakhov/libucl/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1h52ldxankyhbbm1qbqz1f2q0j03c1b4mig7343bs3mc6fpm18gf"))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)
+       ("libtool" ,libtool)))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f)) ;; no tests
+    (home-page "https://github.com/vstakhov/libucl")
+    (synopsis "Universal configuration language parser")
+     (description "libucl is a configuration language
+that is easy to read, write and compatible with JSON.")
+    (license license:bsd-2)))
-- 
2.29.2