diff mbox series

[bug#63915] gnu: Add perl-statistics-distributions.

Message ID 6ff3488be01cc1c60bb886ecd5657ae82f1dbb92.1685991111.git.hrn@posteo.net
State New
Headers show
Series [bug#63915] gnu: Add perl-statistics-distributions. | expand

Commit Message

hrn June 5, 2023, 6:52 p.m. UTC
---
 gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: a025d8fee6c8df1db750058d41f984103eb77978

Comments

宋文武 July 22, 2023, 3:30 a.m. UTC | #1
Rikard Nordgren <hrn@posteo.net> writes:

>  gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)

Pushed to master with minor adjust to synopsis and description, thank
you!
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d7312372de..0b38686d5c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9607,6 +9607,30 @@  (define-public perl-statistics-basic
 @code{median()}, @code{mean()}, @code{variance()} and @code{stddev()}.")
     (license license:lgpl2.0)))
 
+(define-public perl-statistics-distributions
+  (package
+    (name "perl-statistics-distributions")
+    (version "1.02")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/M/MI/MIKEK/Statistics-Distributions-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1j1kswl98f4i9dn176f9aa3y9bissx2sscga5jm3gjl4pxm3k7zr"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/pod/Statistics::Distributions")
+    (synopsis "Perl module for calculating critical values of common
+statistical distributions")
+    (description
+     "This Perl module calculates percentage points (5 significant
+digits) of the u (standard normal) distribution, the student's t distribution,
+the chi-square distribution and the F distribution.  It can also calculate the
+upper probability (5 significant digits) of the u (standard normal), the
+chi-square, the t and the F distribution.")
+    (license license:perl-license)))
+ 
 (define-public perl-statistics-pca
   (package
     (name "perl-statistics-pca")