diff mbox series

[bug#67110,v2] gnu: mympd: Update to 13.0.5.

Message ID 6fef32a0128bdd36b2f4a18234f98a17e3e73cb5.1700501588.git.mirai@makinata.eu
State New
Headers show
Series [bug#67110,v2] gnu: mympd: Update to 13.0.5. | expand

Commit Message

Bruno Victal Nov. 20, 2023, 5:33 p.m. UTC
* gnu/packages/mpd.scm (mympd): Update to 13.0.5.
[native-inputs]: Add jekyll.
[outputs]: Add 'doc.
[arguments]<#:configure-flags>: Install HTML documentation. Set correct value
for localstatedir.
<#:phases>: Add 'move-doc.

Change-Id: I0f1ab4295b7bc03876ad1bbeff6154b4da6adc9a
---
 gnu/packages/mpd.scm | 22 +++++++++++++++-------
 1 file changed, 15 insertions(+), 7 deletions(-)


base-commit: c07a5f050f67fa9054e93479cdda2f298c567460

Comments

Christopher Baines Nov. 23, 2023, 2:35 p.m. UTC | #1
Bruno Victal <mirai@makinata.eu> writes:

> * gnu/packages/mpd.scm (mympd): Update to 13.0.5.
> [native-inputs]: Add jekyll.
> [outputs]: Add 'doc.
> [arguments]<#:configure-flags>: Install HTML documentation. Set correct value
> for localstatedir.
> <#:phases>: Add 'move-doc.
>
> Change-Id: I0f1ab4295b7bc03876ad1bbeff6154b4da6adc9a
> ---
>  gnu/packages/mpd.scm | 22 +++++++++++++++-------
>  1 file changed, 15 insertions(+), 7 deletions(-)

Thanks for the patch, I've pushed it to master as
dbc02656cf4804821e68d655fc871e2365150f43.

It would be good to record in the commit message the motivation for
changes like splitting the doc stuff in to a separate output. I had a
look at the doc output is larger than the main output, so maybe that's
justification enough.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 0e762144a1..e59397ea3a 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -57,6 +57,7 @@  (define-module (gnu packages mpd)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
@@ -622,7 +623,7 @@  (define-public mpdevil
 (define-public mympd
   (package
     (name "mympd")
-    (version "12.1.1")
+    (version "13.0.5")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -631,22 +632,29 @@  (define-public mympd
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1bal31xmdmq46bi0qmia07sqcwy695vcz5y5hxwkz71rcfywbsf9"))))
+                "1ly3iw4irybfxyafgrldldwc28a879wwnd1pg32m2sgrwyhr0czm"))))
+    (outputs '("out" "doc"))
     (build-system cmake-build-system)
     (arguments
      (list
       #:configure-flags
-      #~(list "-DMYMPD_BUILD_TESTING=ON"
-              ;; Handled by 'strip' phase.
-              "-DMYMPD_STRIP_BINARY=OFF")
+      #~(list "-DCMAKE_INSTALL_LOCALSTATEDIR=/var"
+              "-DMYMPD_BUILD_TESTING=ON"
+              "-DMYMPD_DOC_HTML=ON")
       #:phases
       #~(modify-phases %standard-phases
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
                 ;; The following test requires network connectivity.
-                (invoke "ctest" "--exclude-regex" "test_http_client")))))))
-    (native-inputs (list jq perl pkg-config))
+                (invoke "ctest" "--exclude-regex" "test_http_client"))))
+          (add-after 'install 'move-doc
+            (lambda _
+              (let ((old (string-append #$output "/share/doc"))
+                    (new (string-append #$output:doc "/share/doc")))
+                (mkdir-p (dirname new))
+                (rename-file old new)))))))
+    (native-inputs (list jekyll jq perl pkg-config))
     (inputs (list flac libid3tag lua openssl pcre2))
     (home-page "https://jcorporation.github.io/")
     (synopsis "Web-based MPD client")