diff mbox series

[bug#71076,16/81] gnu: Add rust-tikv-jemallocator-0.5.

Message ID 6fbc8eed33fd42900a149050de34cb5b98b3cf49.1716193122.git.herman@rimm.ee
State New
Headers show
Series Add matrix-conduit and ruma-0.10. | expand

Commit Message

Herman Rimm May 20, 2024, 8:58 a.m. UTC
* gnu/packages/crates-io.scm (rust-tikv-jemallocator-0.5): Add
variables.
(rust-tikv-jemallocator-0.4): Inherit from rust-tikv-jemallocator-0.5.

Change-Id: I7c280bbacbffb5aee78dc41d9fc082387992040d
---
 gnu/packages/crates-io.scm | 40 +++++++++++++++++++++++++++++---------
 1 file changed, 31 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8aee499902..16583e582a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -82778,8 +82778,38 @@  (define-public rust-tikv-jemalloc-sys-0.4
         ("rust-fs-extra" ,rust-fs-extra-1)
         ("rust-libc" ,rust-libc-0.2))))))
 
+(define-public rust-tikv-jemallocator-0.5
+  (package
+    (name "rust-tikv-jemallocator")
+    (version "0.5.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tikv-jemallocator" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+          "1jpanfm9az8hcbg6dyxdabykx03lj0j4g9cbwfa6rig5dg1f0pwn"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list
+      #:cargo-test-flags
+      '(list "--release" "--"
+             "--skip=background_threads_enabled")
+      #:cargo-inputs (list rust-libc-0.2 rust-tikv-jemalloc-sys-0.5)
+      #:cargo-development-inputs (list rust-paste-1
+                                       rust-tikv-jemalloc-ctl-0.5)
+      #:phases override-jemalloc))
+    (native-inputs (list jemalloc))
+    (home-page "https://github.com/tikv/jemallocator")
+    (synopsis "Rust allocator backed by jemalloc")
+    (description
+      "This package provides a Rust allocator backed by jemalloc.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-tikv-jemallocator-0.4
   (package
+    (inherit rust-tikv-jemallocator-0.5)
     (name "rust-tikv-jemallocator")
     (version "0.4.1")
     (source
@@ -82791,20 +82821,12 @@  (define-public rust-tikv-jemallocator-0.4
        (sha256
         (base32
          "1pyc94yx74s3vxnr22gnpj0b2f87s0vql0c5ayy1b1zb0jkaa51w"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-libc" ,rust-libc-0.2)
         ("rust-tikv-jemalloc-sys"
-         ,rust-tikv-jemalloc-sys-0.4))))
-    (home-page
-     "https://github.com/tikv/jemallocator")
-    (synopsis
-     "Rust allocator backed by jemalloc")
-    (description
-     "This package provides a Rust allocator backed by jemalloc.")
-    (license (list license:expat license:asl2.0))))
+         ,rust-tikv-jemalloc-sys-0.4))))))
 
 (define-public rust-time-0.3
   (package