diff mbox series

[bug#59749] gnu: minetest: Add minetest-oneblock.

Message ID 6fbc1b962b6bd38bb09f073e9541c0ccce8a28ce.camel@planete-kraus.eu
State New
Headers show
Series [bug#59749] gnu: minetest: Add minetest-oneblock. | expand

Commit Message

Vivien Kraus Dec. 1, 2022, 8:11 p.m. UTC
* gnu/packages/minetest.scm (minetest-oneblock): New variable.
---
 gnu/packages/minetest.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: c7793b82efd3383a9f7adf0dfa82d71ee032e41b

Comments

Vivien Kraus Dec. 1, 2022, 9 p.m. UTC | #1
Dear guix,

oneblock is a Minetest mod where you sit on top of an indestructible
block that generates random objects of the game every 30 seconds. It is
very fun to play, especially when you have many many mods. It’s slow to
start, because getting wood is rare enough that making a chest takes
time. Other than that, it is pretty fun!

Best regards,

Vivien
diff mbox series

Patch

diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index f5671241a7..2c26ab08a8 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -746,3 +746,25 @@  (define-public minetest-basic-trains
 advtrains up to version 2.2.1.")
     (license (list license:cc-by-sa3.0 license:agpl3+))
     (properties `((upstream-name . "orwell/basic_trains")))))
+
+(define-public minetest-oneblock
+  (package
+    (name "minetest-oneblock")
+    (version "2022-09-01")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/NO411/oneblock")
+                    (commit "3582c825137e61b3d2ae3d60b8b9746acd6dfe3d")))
+              (sha256
+               (base32
+                "1pkdrj99qqwmz7c86w2mh081ynyxhiwv2rl01xjm1wfpazx5zhdg"))
+              (file-name (git-file-name name version))))
+    (build-system minetest-mod-build-system)
+    (home-page "https://github.com/NO411/oneblock")
+    (synopsis "Build your island in the sky with random items!")
+    (description
+     "Build your island in the sky.  Every 30 seconds you will receive a random
+block or item from the oneblock to expand the island!")
+    (license license:gpl3)
+    (properties `((upstream-name . "NO11/oneblock")))))