diff mbox series

[bug#72133,1/2] gnu: Add python-pandapower.

Message ID 6f763535fd29b3b0b82de04f8c6e4ccd0289c498.1721091992.git.monego@posteo.net
State New
Headers show
Series Add python-pandapower and python-pandapipes | expand

Commit Message

Vinicius Monego July 16, 2024, 1:10 a.m. UTC
* gnu/packages/engineering.scm (python-pandapower): New variable.

Change-Id: I08bbb31df0e8c9918f331c420eb2f3ac136b69a8
---
 gnu/packages/engineering.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cc9020c6fd..6e204e6b6d 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2627,6 +2627,40 @@  (define-public python-pyvisa
 measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
     (license license:expat)))
 
+(define-public python-pandapower
+  (package
+    (name "python-pandapower")
+    (version "2.14.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pandapower" version ".zip"))
+       (sha256
+        (base32 "0c5vgiq795kd5q4wcy2x7s3l7x9xdj2nqyfx188dmhgqckrym161"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pyproj python-pytest unzip))
+    (propagated-inputs (list python-deepdiff
+                             python-geojson
+                             python-networkx
+                             python-numpy
+                             python-packaging
+                             python-pandas
+                             python-scipy
+                             python-tqdm
+                             python-typing-extensions))
+    (home-page "https://www.pandapower.org/")
+    (synopsis "Power system modelling and analysis")
+    (description "@code{pandapower} is an easy to use network calculation
+program aimed to automate the analysis and optimization of power systems.
+It uses the data analysis library @code{pandas} and is compatible with the
+commonly used @code{MATPOWER} / @code{PYPOWER} case format.  @code{pandapower}
+allows using different solvers including an improved Newton-Raphson power flow
+implementation, all @code{PYPOWER} solvers, the C++ library solvers for fast
+steady-state distribution power system analysis of @code{PowerGridModel}, the
+Newton-Raphson power flow solvers in the C++ library lightsim2grid, and the
+@code{PowerModels.jl} library.")
+    (license license:bsd-3)))
+
 (define-public python-scikit-rf
   (package
     (name "python-scikit-rf")