diff mbox series

[bug#50542] gnu: patchutils: Update to 0.4.2.

Message ID 6f76305fbf225bdf781daf83b85a2b6574640a73.1631436303.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#50542] gnu: patchutils: Update to 0.4.2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Sept. 12, 2021, 8:45 a.m. UTC
* gnu/packages/patchutils.scm (patchutils): Update to 0.4.2.
[source]: Remove patch.
[inputs]: Add ‘python’.
[arguments]<#:phases>: Remove trailing #t.
* gnu/local.mk (dist_patch_DATA): Remove patch.
---
 gnu/local.mk                |  1 -
 gnu/packages/patchutils.scm | 26 +++++++++++++-------------
 2 files changed, 13 insertions(+), 14 deletions(-)


base-commit: f8f94cc5446753b37ab3ddd23e21919efd006769

Comments

Ludovic Courtès Sept. 21, 2021, 1 p.m. UTC | #1
Hi,

Xinglu Chen <public@yoctocell.xyz> skribis:

> * gnu/packages/patchutils.scm (patchutils): Update to 0.4.2.
> [source]: Remove patch.
> [inputs]: Add ‘python’.
> [arguments]<#:phases>: Remove trailing #t.
> * gnu/local.mk (dist_patch_DATA): Remove patch.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 2a56c4a9e2..c99086fcaf 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1568,7 +1568,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/smalltalk-multiplication-overflow.patch	\
   %D%/packages/patches/sqlite-hurd.patch			\
   %D%/packages/patches/sunxi-tools-remove-sys-io.patch	\
-  %D%/packages/patches/patchutils-test-perms.patch		\
   %D%/packages/patches/patch-hurd-path-max.patch		\
   %D%/packages/patches/perl-autosplit-default-time.patch	\
   %D%/packages/patches/perl-cross.patch				\
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index cefced86f2..1f3ea994c3 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -52,18 +53,19 @@ 
 (define-public patchutils
   (package
     (name "patchutils")
-    (version "0.3.4")
+    (version "0.4.2")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append "http://cyberelk.net/tim/data/patchutils/stable/"
-                          name "-" version ".tar.xz"))
-      (sha256
-       (base32
-        "0xp8mcfyi5nmb5a2zi5ibmyshxkb1zv1dgmnyn413m7ahgdx8mfg"))
-      (patches (search-patches "patchutils-test-perms.patch"))))
+       (method url-fetch)
+       (uri (string-append "http://cyberelk.net/tim/data/patchutils/stable/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1va5pzmxbzpi87vdnbjm9qdf9bvzps9xfv0gi4mycgg3bybb0xc8"))))
     (build-system gnu-build-system)
-    (inputs `(("perl" ,perl)))
+    (inputs
+     `(("perl" ,perl)
+       ("python" ,python)))
     (arguments
      '(#:parallel-tests? #f
        #:phases
@@ -71,8 +73,7 @@ 
          (add-before 'check 'patch-test-scripts
            (lambda _
              (substitute* (find-files "tests" "^run-test$")
-               (("/bin/echo") (which "echo")))
-             #t))
+               (("/bin/echo") (which "echo")))))
          (add-after 'install 'wrap-program
            ;; Point installed scripts to the utilities they need.
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -87,8 +88,7 @@ 
                       ,(map (lambda (dir)
                               (string-append dir "/bin"))
                             (list diffutils sed gawk)))))
-                '("dehtmldiff" "editdiff" "espdiff")))
-             #t)))))
+                '("dehtmldiff" "editdiff" "espdiff"))))))))
     (home-page "http://cyberelk.net/tim/software/patchutils")
     (synopsis "Collection of tools for manipulating patch files")
     (description