@@ -23,6 +23,7 @@ (define-module (gnu packages perl6)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system perl)
#:use-module (guix build-system rakudo)
#:use-module (gnu packages bdw-gc)
@@ -98,6 +99,30 @@ (define-public moarvm
@end itemize")
(license license:artistic2.0)))
+(define-public nqp-configure
+ (let ((commit "9b98931e0bfb8c4aac61590edf5074e63aa8ea4b" )
+ (revision "0"))
+ (package
+ (name "nqp-configure")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/Raku/nqp-configure")
+ (commit commit)))
+ (sha256 (base32 "1vc1q11kjb964jal9dhgf5vwp371a3rfw7gj987n33kzli7a10n0"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("lib" "lib")
+ ("bin" "bin"))))
+ (synopsis "Configuration utility for NQP and Rakudo installations")
+ (description "A utility that simplifies the process of compiling and
+installing NQP (Not Quite Perl) and the Rakudo Raku compiler.")
+ (license license:artistic2.0)
+ (home-page "https://github.com/Raku/nqp-configure" ))))
+
(define-public nqp
(package
(name "nqp")
This second patch adds nqp-configure. Please see the commit message for an explanation of why it makes sense to factor this out to its own package. Best, Daniel From 76d8df0bd8042e4da035772d5e8e3e6c22374b0a Mon Sep 17 00:00:00 2001 Message-Id: <76d8df0bd8042e4da035772d5e8e3e6c22374b0a.1661877430.git.daniel@codesections.com> From: Daniel Sockwell <daniel@codesections.com> Date: Tue, 30 Aug 2022 12:33:33 -0400 Subject: [PATCH] Add nqp-configure This package adds nqp-configure, a utility package that both NQP (the Raku subset used for compiler writing) and Rakudo (the compiler) depend on. Adding it as a seperate package avoids the need for those two packages to pull the script down directly from GitHub (as the upstream instructions provide). --- gnu/packages/perl6.scm | 25 +++++++++++++++++++++++++ 1 file changed, 25 insertions(+)