From af155a34ae96a4d190fdfb3658927f311c71314f Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Thu, 12 Mar 2020 17:14:37 +0530
Subject: [PATCH] gnu: r-crochet: New variable.
* gnu/packages/cran.scm (r-crochet): Added a New Package Description.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -20752,3 +20752,29 @@ containing elevation data.")
calculate the higher-order partial and semi-partial correlations but also with
statistics and p-values of the correlation coefficients.")
(license license:gpl2)))
+
+(define-public r-crochet
+ (package
+ (name "r-crochet")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "crochet" version))
+ (sha256
+ (base32
+ "1cbv79nyycxk6f8ldcsnn2pvgxqlnrj0qs19nhafnq2clxy863k6"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/agrueneberg/crochet")
+ (synopsis
+ "Implementation Helper for '[' and '[<-' of Custom Matrix-Like Types")
+ (description
+ "Functions to help implement the extraction / subsetting /
+indexing function '[' and replacement function '[<-' of custom matrix-like
+types (based on S3, S4, etc.), modeled as closely to the base matrix class
+as possible (with tests to prove it).")
+ (license license:expat)))
+
+
+
+
--
2.20.1