diff mbox series

[bug#40040] Submission of Patch for Package Description for CRAN Package r-crochet

Message ID 6f2765ba-6120-d07f-828b-c8d1c2609d6e@riseup.net
State Accepted
Headers show
Series [bug#40040] Submission of Patch for Package Description for CRAN Package r-crochet | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari March 12, 2020, 11:46 a.m. UTC
Hi

I am submitting the patch file for CRAN Package Description (r-crochet).

This is my first ever package submission, i have gone through maillists 
as reference to build this.

Comments

Danny Milosavljevic March 12, 2020, 5:06 p.m. UTC | #1
Hi,

that patch does not apply to guix master.

Could you rebase it?

You can do that using

  git pull --rebase

Then you can regenerate the patch via

  git format-patch -1

and send it to this bug report as version 2.

Thanks!

Other than that, I did a license review and that seems fine.

Please do not add trailing newlines at the end of the file.

Please also make sure to use

  ./pre-inst-env guix lint r-crochet

in order to find out obvious problems with it, if any.

In this case, guix lint warns that '[' and other code-like things should be
enclosed in the texinfo tag @code instead, for example:

@code{[}
diff mbox series

Patch

From af155a34ae96a4d190fdfb3658927f311c71314f Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Thu, 12 Mar 2020 17:14:37 +0530
Subject: [PATCH] gnu: r-crochet: New variable.

    * gnu/packages/cran.scm (r-crochet): Added a New Package Description.
---
 gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8cc904612d..41c8055daa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20752,3 +20752,29 @@  containing elevation data.")
 calculate the higher-order partial and semi-partial correlations but also with
 statistics and p-values of the correlation coefficients.")
     (license license:gpl2)))
+
+(define-public r-crochet
+  (package
+    (name "r-crochet")
+    (version "2.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "crochet" version))
+        (sha256
+          (base32
+            "1cbv79nyycxk6f8ldcsnn2pvgxqlnrj0qs19nhafnq2clxy863k6"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/agrueneberg/crochet")
+    (synopsis
+      "Implementation Helper for '[' and '[<-' of Custom Matrix-Like Types")
+    (description
+      "Functions to help implement the extraction / subsetting /
+indexing function '[' and replacement function '[<-' of custom matrix-like 
+types (based on S3, S4, etc.), modeled as closely to the base matrix class 
+as possible (with tests to prove it).")
+    (license license:expat)))
+
+
+
+
-- 
2.20.1