diff mbox series

[bug#50425] gnu: Add minetest-advtrains.

Message ID 6f08e05d775fc7b1e770d1944a2e87130db193d0.camel@planete-kraus.eu
State Accepted
Headers show
Series [bug#50425] gnu: Add minetest-advtrains. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vivien Kraus Sept. 16, 2021, 8:36 a.m. UTC
Hello,

Le jeudi 16 septembre 2021 à 10:03 +0200, Xinglu Chen a écrit :
> > +This modpack contains the trains which were the \"default\" trains
> in
> > +advtrains up to version 2.2.1.")
> 
> I would use ``default'', which is the correct Texinfo syntax,
> instead of "default".  See the Texinfo manual for more details:
> https://www.gnu.org/software/texinfo/manual/texinfo/html_node/Inserting-Quotation-Marks.html
> 
You are correct, I changed it. Guix lint does not like it that much,
because it thinks it is a lazy shortcut for @code{}, but I guess guix
lint can be wrong sometimes.

> > +(define-public minetest-advtrains
> > +  (package
> > +    (name "minetest-advtrains")
> > +    (version "2.3.1")
> > +    (source
> > +     (origin
> > +       (method git-fetch)
> > +       (uri (git-reference
> > +             (url "https://git.bananach.space/advtrains.git")
> > +             (commit "release-2.3.1")))
> 
> This would preferably be (commit (string-append "release-" version)),
> that means that you only have to update the ‘version’ field and the
> hash
> when updating the package (assuming it doesn’t need additional
> dependencies or change build system, etc.).

This is a temporary fix because the contentdb importer (and future
updater) should get the commit ID from the minetest contentdb. For
minetest-advtrains, it is broken right now, so I had to guess which
commit it is, but it may be fixed soon. I added your change because it
makes more sense, but I don’t know if it will be relevant for long.

Vivien
diff mbox series

Patch

From 04d842a8355b9b9dedcfc51b78c3baccdcdb1e64 Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Tue, 7 Sep 2021 12:27:59 +0200
Subject: [PATCH 1/4] gnu: minetest-data: Fix indentation.

* gnu/packages/minetest.scm (minetest-data): Fix indentation.
---
 gnu/packages/minetest.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 5453f4d16a..6f4682ba47 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -154,8 +154,8 @@  in different ways.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/minetest/minetest_game")
-                     (commit version)))
+                    (url "https://github.com/minetest/minetest_game")
+                    (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
@@ -172,8 +172,8 @@  in different ways.")
                                        "/share/minetest/games/minetest_game")))
                      (mkdir-p install-dir)
                      (copy-recursively
-                       (assoc-ref %build-inputs "source")
-                       install-dir)
+                      (assoc-ref %build-inputs "source")
+                      install-dir)
                      #t))))
     (synopsis "Main game data for the Minetest game engine")
     (description
-- 
2.33.0