diff mbox series

[bug#73118,2/5] Fix lib directory of arm-none-eabi libstdc++

Message ID 6ede3b4f8ec273dc19e34f9e6d5942cf80b3c091.1725779196.git.rutherther@protonmail.com
State New
Headers show
Series Fix arm-none-eabi toolchains and introduce a newer version 12.3.rel1 | expand

Commit Message

Rutherther Sept. 8, 2024, 7:49 a.m. UTC
The libstdc++ made for arm-none-eabi puts the contents
into "lib" folder, but that's unexpected when the resulting
toolchain is a cross toolchain.
The folder should be "arm-none-eabi/lib"
---
 gnu/packages/embedded.scm | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index a7ba9ebe98..59ffd9a661 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -481,6 +481,8 @@  (define make-libstdc++-arm-none-eabi
       (package
         (inherit libstdc++)
         (name "libstdc++-arm-none-eabi")
+        ; TODO When --libdir is specified, debug output is not produced.
+        (outputs '("out"))
         (arguments
          (substitute-keyword-arguments (package-arguments libstdc++)
            ((#:configure-flags _)
@@ -493,6 +495,9 @@  (define make-libstdc++-arm-none-eabi
                "--disable-tls"
                "--disable-plugin"
                "--with-newlib"
+               ,(string-append "--libdir="
+                               (assoc-ref %outputs "out")
+                               "/arm-none-eabi/lib")
                ,(string-append "--with-gxx-include-dir="
                                (assoc-ref %outputs "out")
                                "/arm-none-eabi/include/c++")))))