diff mbox series

[bug#40197] gnu: sord: Add pcre to inputs.

Message ID 6ed9c333f5aa1fbb7d5d2f768d9babc223499e30.camel@zrythm.org
State Accepted
Headers show
Series [bug#40197] gnu: sord: Add pcre to inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou March 23, 2020, 4:56 p.m. UTC
Hi,

Sord did not have the `sord_validate` binary (which is needed for
`lv2_validate` from the lv2 package to function properly).

I looked it up and apparently it needs pcre to build:
https://gitlab.com/drobilla/sord/-/blob/master/wscript#L211

I have verified that adding pcre as an input now produces sord_validate
in /bin.

Thanks,
Alex

Comments

Mathieu Othacehe March 23, 2020, 7:54 p.m. UTC | #1
Hello,

> I looked it up and apparently it needs pcre to build:
> https://gitlab.com/drobilla/sord/-/blob/master/wscript#L211
>
> I have verified that adding pcre as an input now produces sord_validate
> in /bin.

Thanks for this patch. I added your copyright, edited a bit the commit
message and pushed.

Mathieu
diff mbox series

Patch

From 3edad6b801d4328e0ebdf9a9244a00fcbd8fda70 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 23 Mar 2020 16:51:44 +0000
Subject: [PATCH] gnu: sord: Add pcre to inputs.

* gnu/packages/rdf.scm (sord): Add pcre needed for sord_validate
---
 gnu/packages/rdf.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index b9abd37e40..15f8d64d43 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -319,6 +319,8 @@  ideal (e.g. in LV2 implementations or embedded applications).")
                     (string-append "-Wl,-rpath="
                                    (assoc-ref outputs "out") "/lib"))
             #t)))))
+    (inputs
+     `(("pcre" ,pcre)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (propagated-inputs
-- 
2.25.1