[bug#77482] gnu: meld: Update to 3.23.0.
Commit Message
* gnu/packages/patchutils.scm (meld): Update to 3.23.0.
[native-inputs]: Add gtk+ "bin".
[arguments] <#:phases>: Delete phase 'skip-gtk-update-icon-cache.
Change-Id: I65c5db4704784a825d87b8029608ead4b22fcf35
---
gnu/packages/patchutils.scm | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)
base-commit: 111aacf22fdc0314f41b737106ad70c1899a58e7
prerequisite-patch-id: a6177f57670ba1e9d303257e10aa60b1fde1bd21
@@ -301,7 +301,7 @@ (define-public vbindiff
(define-public meld
(package
(name "meld")
- (version "3.22.3")
+ (version "3.23.0")
(source
(origin
(method url-fetch)
@@ -309,10 +309,11 @@ (define-public meld
(version-major+minor version)
"/meld-" version ".tar.xz"))
(sha256
- (base32 "114x97rcm4qr91nzw66hys4i1pjnqn1m9388id6yq3zzn6gg5xrp"))))
+ (base32 "19n273shqs8l5lrlic0hr5iv1mp9223ijf3pkh8a49g08112lg4q"))))
(build-system meson-build-system)
(native-inputs
(list desktop-file-utils
+ (list gtk+ "bin") ;for gtk-update-icon-cache
intltool
itstool
libxml2
@@ -339,11 +340,6 @@ (define-public meld
(guix build utils))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
(add-after 'install 'copy-styles
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((styles "/share/gtksourceview-4/styles"))