diff mbox series

[bug#36824] gnu: Add oshu.

Message ID 6e81d4ac2bc090d60b571e266f6c3ebd4ea147ab.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#36824] gnu: Add oshu. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Feb. 21, 2021, 12:36 a.m. UTC
Hello again,

after Nicolas gave me some feedback in IRC I've sorted the package
fields and inputs and also now use @i for "proper names".  This is
somewhat consistent with other packages in Guix.

Regards,
Leo

Am Samstag, den 20.02.2021, 20:07 +0100 schrieb Leo Prikler:
> Hello everyone,
> 
> I'm reviving this old patch and hopefully address most of the issues
> raised for the old one while also sneaking in a version upgrade.
> 
> Regards,
> Leo

Comments

Leo Prikler Feb. 24, 2021, 12:06 a.m. UTC | #1
Am Sonntag, den 21.02.2021, 01:36 +0100 schrieb Leo Prikler:
> Hello again,
> 
> after Nicolas gave me some feedback in IRC I've sorted the package
> fields and inputs and also now use @i for "proper names".  This is
> somewhat consistent with other packages in Guix.
> 
> Regards,
> Leo

Sliding this in as 46c5ae03cef60d78463edd2e5934ed90c1cebcd7.  Hope none
of you want to spin.
diff mbox series

Patch

From 52e8d36dcb0e44133048cf8f3159ebd0e415c5ee Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

* gnu/packages/games.scm (oshu): New variable.

Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
 gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6726cef303..0d4cba471b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8413,6 +8413,45 @@  to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
     (home-page "https://www.stepmania.com")
     (license license:expat)))
 
+(define-public oshu
+  (package
+    (name "oshu")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fmang/oshu")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1g598incc6zlls876slgwqblwiwiszkmqa4xpzw0z7mbjmmzsizz"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           ;; `make test' doesn't actually build the test executable
+           (lambda _ (invoke "make" "zerotokei"))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("ffmpeg" ,ffmpeg)
+       ("pango" ,pango)
+       ("sdl2" ,sdl2)
+       ("sdl2-image" ,sdl2-image)))
+    (home-page "https://github.com/fmang/oshu/")
+    (synopsis "Rhythm game in which you click on circles")
+    (description "@i{oshu!} is a minimalist variant of the @i{osu!} rhythm game,
+which is played by pressing buttons and following along sliders as they appear
+on screen.  Its aim is to be able to play any beatmap even on low-end hardware.
+
+This package provides the core application, but no beatmaps.  You need to
+download and unpack them separately.")
+    (license license:gpl3+)))
+
 (define-public btanks
   (package
     (name "btanks")
-- 
2.30.1