diff mbox series

[bug#71780,2/3] gnu: update go-github-com-protonmail-go-crypto

Message ID 6e7a43c99e5a8de0aad87225c57bb105c64c4290.1719286915.git.woshilapin@tuziwo.info
State New
Headers show
Series add hydroxide package | expand

Commit Message

woshilapin June 26, 2024, 7:33 a.m. UTC
The package also has been reformatted with `guix style`

Change-Id: I10ede00c5237d23024e1b7fa54980a9f9859f4c0
---
 gnu/packages/golang-crypto.scm | 27 ++++++++++++++-------------
 1 file changed, 14 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index baf68b7089..94112973b5 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -378,7 +378,7 @@  (define-public go-github-com-dvsekhvalnov-jose2go
 (define-public go-github-com-emersion-go-pgpmail
   (package
     (name "go-github-com-emersion-go-pgpmail")
-    (version "0.2.0")
+    (version "0.2.1")
     (source
      (origin
        (method git-fetch)
@@ -387,7 +387,7 @@  (define-public go-github-com-emersion-go-pgpmail
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0ar26b0apw5bxn58qfn1a79cxigbmrqm1irh1rb7x57fydihc7wm"))))
+        (base32 "1fiqpdwxnfba2cgij7j83dfqc0zz4mq95x15wicgm5f3vjr1xg5h"))))
     (build-system go-build-system)
     (arguments
      (list ;; tests don't support our version of protonmail/go-crypto; see
@@ -961,7 +961,7 @@  (define-public go-github-com-pion-randutil
 (define-public go-github-com-protonmail-go-crypto
   (package
     (name "go-github-com-protonmail-go-crypto")
-    (version "0.0.0-20220623141421-5afb4c282135")
+    (version "0.0.0-20230923063757-afb1ddc0824c")
     (source
      (origin
        (method git-fetch)
@@ -970,20 +970,21 @@  (define-public go-github-com-protonmail-go-crypto
              (commit (go-version->git-ref version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "05qxdbn8wdk901z5kw2r3jdrag58nxlcsy0p8xd6rq0d71sw94wy"))))
+        (base32 "11q94983r6zjrdvflpikms4773a9s5vb9gg4qw1rj5800yhhah0n"))))
     (build-system go-build-system)
     (arguments
-     (list #:import-path "github.com/ProtonMail/go-crypto"
-           #:tests? #f ; Source-only package.
-           #:phases
-           #~(modify-phases %standard-phases
-               ;; Source-only package.
-               (delete 'build))))
-    (propagated-inputs
-     (list go-golang-org-x-crypto))
+     (list
+      #:import-path "github.com/ProtonMail/go-crypto"
+      #:tests? #f ;Source-only package.
+      #:phases #~(modify-phases %standard-phases
+                   ;; Source-only package.
+                   (delete 'build))))
+    (propagated-inputs (list go-golang-org-x-crypto
+                             go-github-com-cloudflare-circl))
     (home-page "https://github.com/ProtonMail/go-crypto")
     (synopsis "Fork of x/crypto with up-to-date OpenPGP implementation")
-    (description "This package provides cryptography for Go.  This version of
+    (description
+     "This package provides cryptography for Go.  This version of
 the package is a fork that adds a more up-to-date OpenPGP implementation.  It
 is completely backwards compatible with @code{golang.org/x/crypto}, the
 official package.")