@@ -105,6 +105,7 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages bison)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
@@ -138,6 +139,7 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
@@ -232,6 +234,47 @@ (define-public xvkbd
command line, without displaying a keyboard at all.")
(license license:gpl2+)))
+(define-public aquamarine
+ (package
+ (name "aquamarine")
+ (version "0.4.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/aquamarine")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x1zz1ywchs0awkjkvdgskgqnp6pz5lqwmgr8g0zc0i7inhyg1p3"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:cmake cmake-3.30
+ ;; TODO: Figure out what's expected in the test environment.
+ #:tests? #f))
+ (native-inputs
+ (list gcc-13 hyprwayland-scanner pkg-config))
+ (inputs
+ (list eudev
+ hwdata
+ hyprutils
+ libdisplay-info
+ libglvnd
+ libinput-minimal
+ libseat
+ mesa
+ pixman
+ wayland
+ wayland-protocols))
+ (home-page "https://github.com/hyprwm/aquamarine")
+ (synopsis "Linux rendering backend library")
+ (description
+ "Aquamarine is a C++-only Linux rendering backend library. It provides
+basic abstractions for an application to render on a Wayland session (in a
+window) or a native DRM session. It is agnostic of the rendering API (Vulkan
+/ OpenGL).")
+ (license license:bsd-3)))
+
(define-public arandr
(package
(name "arandr")
From: John Kehayias <john.kehayias@protonmail.com> * gnu/packages/wm.scm (aquamarine): New variable. Modified-by: Hilton Chain <hako@ultrarare.space> Change-Id: Ibf62dd86d8dd336a4552d767dc0c235db5e57106 --- gnu/packages/xdisorg.scm | 43 ++++++++++++++++++++++++++++++++++++++++ 1 file changed, 43 insertions(+)