diff mbox series

[bug#66665,v2] gnu: Add clifm.

Message ID 6e21677f082e295034771d944ef67133099c7481.1699989741.git.rodion.goritskov@gmail.com
State New
Headers show
Series [bug#66665,v2] gnu: Add clifm. | expand

Commit Message

Rodion Goritskov Nov. 14, 2023, 7:22 p.m. UTC
* gnu/packages/clifm.scm (clifm): New variable
---
 gnu/packages/clifm.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
 create mode 100644 gnu/packages/clifm.scm


base-commit: bd0f2173210416e86281c1de8789e7cdab66dd57
diff mbox series

Patch

diff --git a/gnu/packages/clifm.scm b/gnu/packages/clifm.scm
new file mode 100644
index 0000000000..091a9298a9
--- /dev/null
+++ b/gnu/packages/clifm.scm
@@ -0,0 +1,58 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Rodion Goritskov <rodion.goritskov@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages clifm)
+  #:use-module (guix packages)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages readline)
+  #:use-module (gnu packages acl)
+  #:use-module (gnu packages linux))
+
+(define-public clifm
+  (package
+    (name "clifm")
+    (version "1.15")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/leo-arch/clifm")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1r9pxlyn8jg0wmzbmbc71l42098lz5k32k6yid09yz6d0gaax7g1"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list (string-append "CC="
+                                         ,(cc-for-target))
+                          (string-append "PREFIX="
+                                         (assoc-ref %outputs "out")))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (delete 'build)
+                  (delete 'check))))
+    (inputs (list readline acl libcap))
+    (home-page "https://github.com/leo-arch/clifm")
+    (synopsis "Command line file manager")
+    (description "Shell-like, text-based terminal file
+manager that sits on the command line.")
+    (license license:gpl2)))