diff mbox series

[bug#70508] gnu: thunar: Use glib-or-gtk-build-system.

Message ID 6e14dd7d2612569cef62640393bc4ebbb4196f70.1713750442.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#70508] gnu: thunar: Use glib-or-gtk-build-system. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via April 22, 2024, 1:47 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

This wraps 'thunar' with GIO_EXTRA_MODULES to enable support for "Trash" and
remote file systems via GVFS.

Fixes <https://issues.guix.gnu.org/55781> and <https://issues.guix.gnu.org/40885>.

* gnu/packages/xfce.scm (thunar)[build-system]: Switch to glib-or-gtk-build-system.

Change-Id: Ifa4bc931272380e7c98dea40edb683da523bbaea
---
 gnu/packages/xfce.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 9fa34ad616b94ad881b5ca48ef88bd84f877a0e9

Comments

宋文武 April 22, 2024, 2:47 a.m. UTC | #1
iyzsong@envs.net writes:

> From: 宋文武 <iyzsong@member.fsf.org>
>
> This wraps 'thunar' with GIO_EXTRA_MODULES to enable support for "Trash" and
> remote file systems via GVFS.
>
> Fixes <https://issues.guix.gnu.org/55781> and <https://issues.guix.gnu.org/40885>.
>
> * gnu/packages/xfce.scm (thunar)[build-system]: Switch to glib-or-gtk-build-system.

Well, it turns out not enough.  The system must also have 'udisks-service-type'
enalbed and gvfs have to be installed for activation via dbus user services.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index f9d9a81169..825b175140 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -736,7 +736,7 @@  (define-public thunar
               (sha256
                (base32
                 "020xrwzdnk5b7cli8vmv3yn7sfq6pg7bz57m4p0xh0ln2cgqlc78"))))
-    (build-system gnu-build-system)
+    (build-system glib-or-gtk-build-system)
     (arguments
      '(#:configure-flags '("--with-custom-thunarx-dirs-enabled")))
     (native-inputs