diff mbox series

[bug#35348] gnu: go@1.4: Update to 1.4-bootstrap-20171003.

Message ID 6d838647-e07c-4713-a5a4-c43ec57cf526@www.fastmail.com
State Accepted
Headers show
Series [bug#35348] gnu: go@1.4: Update to 1.4-bootstrap-20171003. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alex Griffin April 20, 2019, 7:41 p.m. UTC
The Go bootstrap compiler in Guix currently includes a couple unnecessary workarounds for bugs which have already been fixed. This patch switches to using the bootstrap branch which is still maintained upstream.

Comments

Ludovic Courtès May 27, 2019, 2:29 p.m. UTC | #1
Hello Alex,

"Alex Griffin" <a@ajgrf.com> skribis:

> The Go bootstrap compiler in Guix currently includes a couple unnecessary workarounds for bugs which have already been fixed. This patch switches to using the bootstrap branch which is still maintained upstream.

Leo, could you take a look at this patch?

  https://issues.guix.gnu.org/issue/35348

Thanks in advance,
Ludo’.
Leo Famulari May 27, 2019, 5:33 p.m. UTC | #2
On Sat, Apr 20, 2019 at 03:41:34PM -0400, Alex Griffin wrote:
> The Go bootstrap compiler in Guix currently includes a couple
> unnecessary workarounds for bugs which have already been fixed. This
> patch switches to using the bootstrap branch which is still maintained
> upstream.

Thanks for taking care of this!

How did you find this newer tarball? It doesn't appear at
<https://golang.org/dl/> or the Go GitHub page. Can you add a code
comment with a link and send a revised patch?

> From 4d784a54e5736d2eaeac2a6e9ed14c7d11598705 Mon Sep 17 00:00:00 2001
> From: Alex Griffin <a@ajgrf.com>
> Date: Sat, 20 Apr 2019 14:01:17 -0500
> Subject: [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-20171003.
> 
> * gnu/packages/golang.scm (go-1.4): Use the bootstrap branch that is
> still support upstream.
> [version]: Update to 1.4-bootstrap-20171003.
> [arguments]: Remove fix to timezone test which is now included upstream. Don't
> manually disable CGO because it is disabled by default. Manually enable test
> suite because future releases will disable tests by default.

LGTM.

I think the number of packages that will need to be rebuilt is small
enough that we can push this directly to the master branch, and this
update should not have any effect on the later compiler versions, but
did you check that major Go packages like mongo-tools, restic, and
Syncthing still build?
Leo Famulari May 27, 2019, 5:38 p.m. UTC | #3
On Mon, May 27, 2019 at 01:33:02PM -0400, Leo Famulari wrote:
> I think the number of packages that will need to be rebuilt is small
> enough that we can push this directly to the master branch, and this
> update should not have any effect on the later compiler versions, but
> did you check that major Go packages like mongo-tools, restic, and
> Syncthing still build?

I didn't realize you sent your patch so long ago... I will test these
things myself. But can you still let me know how you found the newer
tarball?
Alex Griffin May 27, 2019, 5:46 p.m. UTC | #4
Hi Leo,

I found the tarball on [this page](https://golang.org/doc/install/source#go14). That's also the page to check for updates.

You can see the changes by looking at release-branch.go1.4 in git (https://github.com/golang/go/tree/release-branch.go1.4).

Thanks,
Leo Famulari May 27, 2019, 6:27 p.m. UTC | #5
On Mon, May 27, 2019 at 05:46:44PM +0000, Alex Griffin wrote:
> Hi Leo,
> 
> I found the tarball on [this page](https://golang.org/doc/install/source#go14). That's also the page to check for updates.
> 
> You can see the changes by looking at release-branch.go1.4 in git (https://github.com/golang/go/tree/release-branch.go1.4).

Thanks!

I added a comment and pushed your patch as
521d736ae97ef34f4e6136c7175a99c680c5ac95.
Alex Griffin May 29, 2019, 4:52 p.m. UTC | #6
On Mon, May 27, 2019, at 6:27 PM, Leo Famulari wrote:
> I added a comment [...]

I don't know if it's worth another commit, but you misspelled "langauge" in your comment.

> and pushed your patch as 521d736ae97ef34f4e6136c7175a99c680c5ac95.

Thanks!
Leo Famulari May 31, 2019, 2:31 p.m. UTC | #7
On Wed, May 29, 2019 at 04:52:37PM +0000, Alex Griffin wrote:
> I don't know if it's worth another commit, but you misspelled "langauge" in your comment.

Thanks, fixed in 9bc1de31348858278067a45c5965328677ee74d8
diff mbox series

Patch

From 4d784a54e5736d2eaeac2a6e9ed14c7d11598705 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sat, 20 Apr 2019 14:01:17 -0500
Subject: [PATCH] gnu: go@1.4: Update to 1.4-bootstrap-20171003.

* gnu/packages/golang.scm (go-1.4): Use the bootstrap branch that is
still support upstream.
[version]: Update to 1.4-bootstrap-20171003.
[arguments]: Remove fix to timezone test which is now included upstream. Don't
manually disable CGO because it is disabled by default. Manually enable test
suite because future releases will disable tests by default.
---
 gnu/packages/golang.scm | 18 +++++-------------
 1 file changed, 5 insertions(+), 13 deletions(-)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b44bd3d02..3bd1c3eb8f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright @ 2019 Alex Griffin <a@ajgrf.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,14 +62,14 @@ 
 (define-public go-1.4
   (package
     (name "go")
-    (version "1.4.3")
+    (version "1.4-bootstrap-20171003")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://storage.googleapis.com/golang/"
-                                  name version ".src.tar.gz"))
+                                  name version ".tar.gz"))
               (sha256
                (base32
-                "0na9yqilzpvq0bjndbibfp07wr796gf252y471cip10bbdqgqiwr"))))
+                "0liybk5z00hizsb5ypkbhqcawnwwa6mkwgvjjg4y3jm3ndg5pzzl"))))
     (build-system gnu-build-system)
     (outputs '("out"
                "doc"
@@ -135,13 +136,6 @@ 
                   ("os/os_test.go" "(.+)(TestHostname.+)")
                   ("time/format_test.go" "(.+)(TestParseInSydney.+)")
 
-                  ;; Tzdata 2016g changed the name of the time zone used in this
-                  ;; test, and the patch for Go 1.7 does not work for 1.4.3:
-                  ;; https://github.com/golang/go/issues/17545
-                  ;; https://github.com/golang/go/issues/17276
-                  ("time/time_test.go" "(.+)(TestLoadFixed.+)")
-                  ("time/format_test.go" "(.+)(TestParseInLocation.+)")
-
                   ("os/exec/exec_test.go" "(.+)(TestEcho.+)")
                   ("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
                   ("os/exec/exec_test.go" "(.+)(TestCatStdin.+)")
@@ -168,9 +162,7 @@ 
                (setenv "GOOS" "linux")
                (setenv "GOROOT" (dirname (getcwd)))
                (setenv "GOROOT_FINAL" output)
-               ;; Go 1.4's cgo will not work with binutils >= 2.27:
-               ;; https://github.com/golang/go/issues/16906
-               (setenv "CGO_ENABLED" "0")
+               (setenv "GO14TESTS" "1")
                (invoke "sh" "all.bash"))))
 
          (replace 'install
-- 
2.20.1