diff mbox series

[bug#74223,06/11] gnu: Add hyprcursor.

Message ID 6d7200cd418861aff6d5c86b9a3bb1afa34e4365.1730877074.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add hyprland. | expand

Commit Message

Hilton Chain Nov. 6, 2024, 7:36 a.m. UTC
* gnu/packages/wm.scm (hyprcursor): New variable.

Change-Id: I3e753cbaf75244adca65f0478cabd10c89af4286
---
 gnu/packages/xdisorg.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a75e9cd6ba..033b86231e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -115,6 +115,7 @@  (define-module (gnu packages xdisorg)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gawk)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages gl)
@@ -3638,6 +3639,29 @@  (define-public hsetroot
 This package is the fork of hsetroot by Hyriand.")
     (license license:gpl2+)))
 
+(define-public hyprcursor
+  (package
+    (name "hyprcursor")
+    (version "0.1.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hyprwm/hyprcursor")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rdn03ln7pqcwp8h4nmi7nc489q8y25dd3v4paq8ykvwzhvs3a1n"))))
+    (build-system cmake-build-system)
+    (arguments (list #:tests? #f))      ;TODO: No themes currently packaged.
+    (native-inputs (list gcc-13 pkg-config))
+    (inputs (list cairo hyprlang (librsvg-for-system) libzip tomlplusplus))
+    (home-page "https://standards.hyprland.org/hyprcursor/")
+    (synopsis "Cursor theme format")
+    (description
+     "This package provides Hyprland cursor format, library and utilities.")
+    (license license:bsd-3)))
+
 (define-public jumpapp
   (package
     (name "jumpapp")