[bug#77209] gnu: Add emacs-elastic-modes.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-elastic-modes): New variable.
Change-Id: I41f0b6cdb9ad4a2a6c7a178229c791b6499e77c3
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
base-commit: 4ea012fc6ddcb32574fbd4a854b11808c34fbca8
Comments
user guix
usertag 77209 + reviewed-looks-good
thanks
Items marked as checked:
- commit messages
- package builds
- lint warnings
- package style
- no dependent package build
- synopsis and descriptions
- no package tests
- licenses
- synopsis and descriptions
Am Sonntag, dem 23.03.2025 um 16:36 +0100 schrieb Nicolas Goaziou:
> * gnu/packages/emacs-xyz.scm (emacs-elastic-modes): New variable.
>
> Change-Id: I41f0b6cdb9ad4a2a6c7a178229c791b6499e77c3
Am Sonntag, dem 23.03.2025 um 17:51 +0100 schrieb Cayetano Santos:
> user guix
> usertag 77209 + reviewed-looks-good
> thanks
>
> Items marked as checked:
>
> - commit messages
> - package builds
> - lint warnings
> - package style
> - no dependent package build
> - synopsis and descriptions
> - no package tests
> - licenses
> - synopsis and descriptions
And pushed.
Thanks
@@ -10040,6 +10040,30 @@ (define-public emacs-el-job
not hang at all.")
(license license:gpl3+)))
+(define-public emacs-elastic-modes
+ (let ((commit "ea49bb03b78cb9fd17655990223e3095f137a3ce")
+ (revision "1"))
+ (package
+ (name "emacs-elastic-modes")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/elastic-modes")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dkigkjw4i9nz5rl0dnic16ljdnp5cyz2xic3hc2myqnjlqnc6z6"))))
+ (build-system emacs-build-system)
+ (arguments (list #:tests? #false)) ;no tests
+ (propagated-inputs (list emacs-dash))
+ (home-page "https://github.com/jyp/elastic-modes")
+ (synopsis "Text and code alignment for variable-width fonts")
+ (description
+ "This is an Emacs package for text and code alignment for
+variable-width (i.e., proportional, or variable pitch) fonts.")
+ (license license:gpl3+))))
(define-public emacs-elisp-demos
(package