diff mbox series

[bug#50077,3/3] gnu: notmuch: Use 'cc-for-target' instead of hardcoding 'gcc'.

Message ID 6ce89bf8646d07c68dc5b27b0795de45030b4adc.1629122681.git.public@yoctocell.xyz
State Accepted
Headers show
Series Various improvements to Notmuch | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Aug. 16, 2021, 2:12 p.m. UTC
* gnu/packages/mail.scm (notmuch)[arguments]<#:phases>: Use 'cc-for-target'
  instead of 'gcc'.
---
 gnu/packages/mail.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 66e0d2482d..2c2d740f9b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1352,7 +1352,7 @@  invoking @command{notifymuch} from the post-new hook.")
                         (("/bin/sh") (which "sh")))))
                   (replace 'configure
                     (lambda* (#:key outputs #:allow-other-keys)
-                      (setenv "CC" "gcc")
+                      (setenv "CC" ,(cc-for-target))
                       (setenv "CONFIG_SHELL" (which "sh"))
 
                       (let* ((out (assoc-ref outputs "out"))
@@ -1370,7 +1370,7 @@  invoking @command{notifymuch} from the post-new hook.")
                         (("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))))
                   (add-before 'check 'prepare-test-environment
                     (lambda _
-                      (setenv "TEST_CC" "gcc")
+                      (setenv "TEST_CC" ,(cc-for-target))
                       ;; Patch various inline shell invocations.
                       (substitute* (find-files "test" "\\.sh$")
                         (("/bin/sh") (which "sh")))))