[bug#76513,rust-team,08/77] gnu: Add rust-imagesize-0.13.

Message ID 6cd09f33e513318bf9b8ef0e7f8cc9e79de2f9e0.1740340805.git.wongandj@icloud.com
State New
Headers
Series Add module (gnu packages typst) and packages |

Commit Message

Andrew Wong Feb. 23, 2025, 8:20 p.m. UTC
  * gnu/packages/crates-graphics.scm (rust-imagesize-0.13): New variable.

Change-Id: I7cb064276e26049546e840af12ea412e865c77c9
---
 gnu/packages/crates-graphics.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 79721b1dc4..f2df578834 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2636,6 +2636,27 @@  (define-public rust-imageproc-0.23
         ("rust-quickcheck" ,rust-quickcheck-0.9)
         ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3))))))
 
+(define-public rust-imagesize-0.13
+  (package
+    (name "rust-imagesize")
+    (version "0.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "imagesize" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "11f26ac9zvbr7sjnsv2z9jd3ryaz40pg8xch4ij1q1rg5zbjgkgd"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/Roughsketch/imagesize")
+    (synopsis
+     "Quick probing of image dimensions without loading the entire file")
+    (description
+     "This package provides Quick probing of image dimensions without loading the entire file.")
+    (license license:expat)))
+
 (define-public rust-imgref-1
   (package
     (name "rust-imgref")