diff mbox series

[bug#57456] gnu: Add neovim-packer.

Message ID 6cd04239206a8a85b0d20ec5a5904b071d800b53.1661660180.git.me@gyara.moe
State Accepted
Headers show
Series [bug#57456] gnu: Add neovim-packer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

ギャラ Aug. 28, 2022, 4:16 a.m. UTC
---
This patch add neovim-packer, a neovim plugin manager to guix.

 gnu/packages/vim.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

\( Aug. 28, 2022, 7:38 a.m. UTC | #1
Hello!

On Sun Aug 28, 2022 at 5:16 AM BST, gyara via Guix-patches via wrote:
> +  (let ((commit "3a9f9801f683946b9f1047d8f4bf9946c29e927d")
> +        (revision "1"))

Change to `0`, since this is the first revision in Guix.

> +    (package
> +      (name "neovim-packer")
> +      (version (git-version "0.0.0" revision commit))
> +      (home-page "https://github.com/wbthomason/packer.nvim")

Move this above `synopsis`.

> +                (uri (git-reference
> +                      (url "https://github.com/wbthomason/packer.nvim.git")

Remove the `.git` part.

> +      (arguments
> +       '(#:install-plan '(("lua"
> +                           "share/nvim/site/pack/packer/start/packer.nvim/")
> +                          ("doc"
> +                           "share/nvim/site/pack/packer/start/packer.nvim/"))))

Probably better formatting:

  (arguments
   (list #:install-plan
         #~'(("doc" "share/nvim/site/pack/guix/start/packer/")
             ("lua" "share/nvim/site/pack/guix/start/packer/"))))

(I used site/guix instead of site/packer for my own Guix
neovim packages; it seems like any name after site/ works.)

> +      (synopsis "Neovim Plugin manager")

This might be better as:

  Plugin manager for Neovim

> +      (description
> +       "A use-package inspired plugin manager for Neovim. Uses native packages,
> +      supports Luarocks dependencies, written in Lua, allows for expressive config")

And this as:

  This package provides a plugin manager for Neovim, inspired by Emacs's
  @code{euse-package}.  It's written in Lua, supports Luarocks dependencies,
  and is based on Vim's builtin plugin support.

    -- (
ギャラ Aug. 28, 2022, 8:21 a.m. UTC | #2
Thanks for your review!

Updated patch is followed.

-- 
存在するということは、自分を创造することだ。
ギャラ Aug. 29, 2022, 4:01 a.m. UTC | #3
After some test, I find that packer need to be place in 
`pack/*/*/packer.nvim` because That plugin code relay on it.

-- 
存在するということは、自分を创造することだ。
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index a07c681cb3..d1d8588562 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -639,6 +639,34 @@  (define-public editorconfig-vim
 editors.")
     (license license:bsd-2)))
 
+(define-public neovim-packer
+  (let ((commit "3a9f9801f683946b9f1047d8f4bf9946c29e927d")
+        (revision "1"))
+    (package
+      (name "neovim-packer")
+      (version (git-version "0.0.0" revision commit))
+      (home-page "https://github.com/wbthomason/packer.nvim")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/wbthomason/packer.nvim.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1xn08z3a21mgfvp5i1nv57jnldwxwnl5nkryiff3zc99b1mizigp"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("lua"
+                           "share/nvim/site/pack/packer/start/packer.nvim/")
+                          ("doc"
+                           "share/nvim/site/pack/packer/start/packer.nvim/"))))
+      (synopsis "Neovim Plugin manager")
+      (description
+       "A use-package inspired plugin manager for Neovim. Uses native packages,
+      supports Luarocks dependencies, written in Lua, allows for expressive config")
+      (license license:expat))))
+
 (define-public neovim-syntastic
   (package
     (inherit vim-syntastic)