diff mbox series

[bug#74397,v2] gnu: Update otpclient to 4.0.2

Message ID 6c9a8cced8ecead9f4f513868467067f18137676.1731857399.git.ekaitz@elenq.tech
State New
Headers show
Series [bug#74397,v2] gnu: Update otpclient to 4.0.2 | expand

Commit Message

Ekaitz Zarraga Nov. 17, 2024, 3:29 p.m. UTC
Requires updating `libcotp` to 3.1.0, that introduced a new way for
testing that requires `criterium`, a package we don't have and that has
dependencies that we don't have either.

As the tests in `libcotp` are not an exhaustive testsuite and
`otpclient` is its only dependent package, tests are disabled for the
moment.

* gnu/packages/authentication.scm (libcotp): Update to 3.1.0
[arguments] Disable tests.
* gnu/packages/password-utils.scm (otpclient): Update to 4.0.2

Change-Id: Ie6d37b5efe59397d4979c7490b94f1c871c27d6d
---
 gnu/packages/authentication.scm | 10 ++++++++--
 gnu/packages/password-utils.scm |  4 ++--
 2 files changed, 10 insertions(+), 4 deletions(-)


base-commit: d108a7aac2c51f21c55cb8ea8801629a97f5242a
diff mbox series

Patch

diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index da778de4cb..d6b5cedb20 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -39,7 +39,7 @@  (define-module (gnu packages authentication)
 (define-public libcotp
   (package
     (name "libcotp")
-    (version "2.0.1")
+    (version "3.1.0")
     (source
      (origin
        (method git-fetch)
@@ -48,8 +48,14 @@  (define-public libcotp
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "12ps2msclcbv53gjf936cny10an8sc70b9frp6xxjirfn5jg2h63"))))
+        (base32 "1lw15blzzds3qq4ydhi6fsk189p1rbvzy5fzz4r3fv6wlmcyyprs"))))
     (build-system cmake-build-system)
+    (arguments `(#:tests? #f))
+    ;; TODO: tests:
+    ;; Tests can be built with -DBUILD_TESTS=on.
+    ;; Tests don't have a general `check` target so they have to be run manually.
+    ;; Tests require `criterion`, which is not included in guix and has several
+    ;; bundled dependencies.
     (inputs (list libgcrypt))
     (native-inputs (list pkg-config))
     (home-page "https://github.com/paolostivanin/libcotp")
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index dcd155835a..2820fa60d0 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -328,7 +328,7 @@  (define-public pwsafe-cli
 (define-public otpclient
   (package
     (name "otpclient")
-    (version "3.1.9")
+    (version "4.0.2")
     (source
      (origin
        (method git-fetch)
@@ -337,7 +337,7 @@  (define-public otpclient
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0n5h76zwchdp3nbiczcfcg9sr0hbfs1npwq26x78rz8jf6md898m"))))
+        (base32 "061idzh9sz556nm7ahjrvcbnbmgvgfwmph1lfiy7bcvj1g3rf8cm"))))
     (build-system cmake-build-system)
     (arguments
      (list