diff mbox series

[bug#64170] gnu: recastnavigation: Update to 1.6.0.

Message ID 6c6200ac3b6af218893eb6bb125f045ba481537a.1687188150.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#64170] gnu: recastnavigation: Update to 1.6.0. | expand

Commit Message

Kaelyn Takata June 19, 2023, 3:22 p.m. UTC
* gnu/packages/game-development.scm (recastnavigation): Update to 1.6.0 and
fix indentation after removing the LET expression defining the commit and
revision to use.
---
 gnu/packages/game-development.scm | 47 +++++++++++++++----------------
 1 file changed, 22 insertions(+), 25 deletions(-)


base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f
--
2.40.1

Comments

Christopher Baines June 20, 2023, 9:32 p.m. UTC | #1
Kaelyn Takata via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/game-development.scm (recastnavigation): Update to 1.6.0 and
> fix indentation after removing the LET expression defining the commit and
> revision to use.
> ---
>  gnu/packages/game-development.scm | 47 +++++++++++++++----------------
>  1 file changed, 22 insertions(+), 25 deletions(-)

Thanks for the patch, I've pushed it to master as
744c979b8fdda5a66490b90327db543be3276380.

I did shorten the commit message a bit, as I don't think it's necessary
to describe the indentation change.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 431bd5c5e4..aa99109cca 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2809,29 +2809,26 @@  (define-public tesseract-engine
       (license license:zlib))))

 (define-public recastnavigation
-  ;; We follow master since there hasn't been a release since 1.5.1 in 2016.
-  (let ((commit "6d1f9711b3b71f28c2c1c0742d76e0ef8766cf91")
-        (revision "2"))
-    (package
-      (name "recastnavigation")
-      (version (git-version "1.5.1" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/recastnavigation/recastnavigation")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0cqp0sbm0ixqnxqz6gf2gybh5l4az91mdsd8b5bgxs1wpl2jmnga"))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
-                                 "-DRECASTNAVIGATION_DEMO=OFF"
-                                 "-DRECASTNAVIGATION_TESTS=ON"
-                                 "-DRECASTNAVIGATION_EXAMPLES=OFF")))
-      (synopsis "Navigation system for games")
-      (description "Recast is state of the art navigation mesh
+  (package
+    (name "recastnavigation")
+    (version "1.6.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/recastnavigation/recastnavigation")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0rdz3qmp4b961zjah2ax82h471j14w2rcf576gcyx7vldrg8dmj8"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
+                               "-DRECASTNAVIGATION_DEMO=OFF"
+                               "-DRECASTNAVIGATION_TESTS=ON"
+                               "-DRECASTNAVIGATION_EXAMPLES=OFF")))
+    (synopsis "Navigation system for games")
+    (description "Recast is state of the art navigation mesh
 construction toolset for games.

 @itemize
@@ -2854,8 +2851,8 @@  (define-public recastnavigation
 in and out pieces of the mesh.  The tiled mesh allows you to create
 systems where you stream new navigation data in and out as the player
 progresses the level, or you may regenerate tiles as the world changes.")
-      (home-page "https://github.com/recastnavigation/recastnavigation")
-      (license license:zlib))))
+    (home-page "https://github.com/recastnavigation/recastnavigation")
+    (license license:zlib)))

 (define-public raylib
   (package