[bug#76150,09/16] gnu: singular: Use G-Expressions.

Message ID 6c5f5034d72976249920afbdf3ce28a6de4d0701.1739064949.git.monego@posteo.net
State New
Headers
Series More patches towards SageMath. |

Commit Message

Vinicius Monego Feb. 9, 2025, 1:52 a.m. UTC
  * gnu/packages/algebra.scm (singular)[arguments]: Use
G-Expressions. Move below build-system.

Change-Id: I4253b8a9a9cd3b7d2b7492853323d1e8c4fbec4e
---
 gnu/packages/algebra.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index acbc76b4ca..b69b14fa28 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -617,6 +617,10 @@  (define-public singular
               (base32
                "0625541pxxhs7789i3ddf5fm1pqvf1kyljyaii41djg9j12cdhbc"))))
    (build-system gnu-build-system)
+   (arguments
+    (list
+     #:configure-flags #~(list (string-append "--with-ntl="
+                                              #$(this-package-input "ntl")))))
    (native-inputs
     (list doxygen graphviz perl))
    (inputs
@@ -627,10 +631,6 @@  (define-public singular
           ntl
           python-2
           readline))
-   (arguments
-    `(#:configure-flags
-      (list (string-append "--with-ntl="
-                           (assoc-ref %build-inputs "ntl")))))
    (synopsis "Computer algebra system for polynomial computations")
    (description
     "Singular is a computer algebra system for polynomial computations,