diff mbox series

[bug#69568] gnu: Add alsa-midi-latency-test.

Message ID 6c5bf499c159e1c01846590b4cc52f840d3dce2e.1709671942.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#69568] gnu: Add alsa-midi-latency-test. | expand

Commit Message

Giacomo Leidi March 5, 2024, 8:52 p.m. UTC
* gnu/packages/audio.scm (alsa-midi-latency-test): New variable.

Change-Id: I35d3047cb997c5787de515a38ae0a0eb8f12600d
---
 gnu/packages/audio.scm | 44 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 43 insertions(+), 1 deletion(-)


base-commit: f18d13b5f89c161c6ee88d15ecdaa8d973ee4503

Comments

Ludovic Courtès March 19, 2024, 4:30 p.m. UTC | #1
Hi,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

> * gnu/packages/audio.scm (alsa-midi-latency-test): New variable.
>
> Change-Id: I35d3047cb997c5787de515a38ae0a0eb8f12600d

I passed it through ‘guix style’ and changed the license to ‘gpl2+’
since nothing states that it’s version 2 only.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 578a0bd016..46897bf213 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -31,7 +31,7 @@ 
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
-;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2024 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020, 2021, 2023 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
@@ -261,6 +261,48 @@  (define-public wildmidi
       ;; Player.
       license:gpl3+))))
 
+(define-public alsa-midi-latency-test
+  (let ((version "0.0.5")
+        (revision "0")
+        (commit "07e43f8a1e6fd6d3bd97a00f2ee5afb74cb66f95"))
+    (package
+      (name "alsa-midi-latency-test")
+      (version (git-version version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/koppi/alsa-midi-latency-test")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0b3xd4z7zx6mmh6q2q7wnyd0hzikny2cikwzhaab3q86b551vb9n"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+        ;; There are no tests.
+        #:tests? #f
+        #:phases
+        #~(modify-phases %standard-phases
+            (replace 'bootstrap
+              (lambda _
+                (invoke "sh" "./autogen.sh"))))))
+      (native-inputs
+       (list
+        automake
+        autoconf
+        libtool))
+      (inputs (list alsa-lib))
+      (synopsis
+       "Measure the roundtrip time of MIDI messages")
+      (description
+       "@code{alsa-midi-latency-test} measures the roundtrip time of a MIDI
+message in the alsa subsystem of the Linux kernel using a high precision timer.
+It calculates the worst case roundtrip time of all sent MIDI messages and
+displays a histogram of the roundtrip time jitter.")
+      (home-page "https://github.com/koppi/alsa-midi-latency-test")
+      (license license:gpl2))))
+
 (define-public webrtc-audio-processing
   (package
     (name "webrtc-audio-processing")