@@ -722,6 +722,29 @@ (define-public go-github-com-chris-ramon-douceur
(description "This package provides a CSS parser and inliner.")
(license license:expat)))
+(define-public go-github-com-coder-websocket
+ (package
+ (name "go-github-com-coder-websocket")
+ (version "1.8.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coder/websocket")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "172v9mqghswf50ga512qghb6ii0ivz5fi2iyjzdnbm42g0cr4fjj"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/coder/websocket"))
+ (home-page "https://github.com/coder/websocket")
+ (synopsis "WebSocket library for Go")
+ (description
+ "@code{websocket} is a minimal and idiomatic
+@url{https://websockets.spec.whatwg.org/, WebSocket} library for Go.")
+ (license license:isc)))
+
(define-public go-github-com-containerd-typeurl
(package
(name "go-github-com-containerd-typeurl")