[bug#78457] gnu: linux-libre: Do not build the SND_PCSP driver.
Commit Message
This snd-pcsp driver apparently attempts to load the pcspkr driver even when
it's already been loaded, causing the infamous kernel error message:
Error: Driver 'pcspkr' is already registered, aborting...
This change fixes it by simply not building the snd-pcsp driver, which usage
is to try to play audio via the low quality builtin speaker/beeper hardware.
It was automated via the command:
git grep -l 'CONFIG_SND_PCSP=m' |
xargs sed -i 's/CONFIG_SND_PCSP=m/# CONFIG_SND_PCSP is not set/'
Change-Id: Ide4b73be107d170a6db6be69b7a6bcd7b8036dcb
---
gnu/packages/aux-files/linux-libre/5.10-i686.conf | 2 +-
gnu/packages/aux-files/linux-libre/5.10-x86_64.conf | 2 +-
gnu/packages/aux-files/linux-libre/5.15-i686.conf | 2 +-
gnu/packages/aux-files/linux-libre/5.15-x86_64.conf | 2 +-
gnu/packages/aux-files/linux-libre/5.4-i686.conf | 2 +-
gnu/packages/aux-files/linux-libre/5.4-x86_64.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.1-i686.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.1-x86_64.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.12-i686.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.12-x86_64.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.14-i686.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.14-x86_64.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.6-i686.conf | 2 +-
gnu/packages/aux-files/linux-libre/6.6-x86_64.conf | 2 +-
14 files changed, 14 insertions(+), 14 deletions(-)
base-commit: d6d03854b57b665ea42bc3e0a04b3e9be66798d8
Comments
Hi,
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
> This snd-pcsp driver apparently attempts to load the pcspkr driver even when
> it's already been loaded, causing the infamous kernel error message:
>
> Error: Driver 'pcspkr' is already registered, aborting...
>
> This change fixes it by simply not building the snd-pcsp driver, which usage
> is to try to play audio via the low quality builtin speaker/beeper hardware.
> It was automated via the command:
>
> git grep -l 'CONFIG_SND_PCSP=m' |
> xargs sed -i 's/CONFIG_SND_PCSP=m/# CONFIG_SND_PCSP is not set/'
>
> Change-Id: Ide4b73be107d170a6db6be69b7a6bcd7b8036dcb
I'm CC'ing the kernel team manually, as the configuration files were not
in its scope (now fixed in teams.scm).
@@ -6690,7 +6690,7 @@ CONFIG_SND_OPL4_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -6619,7 +6619,7 @@ CONFIG_SND_OPL3_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -6850,7 +6850,7 @@ CONFIG_SND_OPL4_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -6804,7 +6804,7 @@ CONFIG_SND_OPL3_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -6509,7 +6509,7 @@ CONFIG_SND_OPL4_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -6417,7 +6417,7 @@ CONFIG_SND_OPL3_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -7104,7 +7104,7 @@ CONFIG_SND_OPL4_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -7085,7 +7085,7 @@ CONFIG_SND_OPL3_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
@@ -7432,7 +7432,7 @@ CONFIG_SND_OPL4_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
# CONFIG_SND_PCMTEST is not set
@@ -7508,7 +7508,7 @@ CONFIG_SND_OPL3_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
# CONFIG_SND_PCMTEST is not set
@@ -7472,7 +7472,7 @@ CONFIG_SND_OPL4_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
# CONFIG_SND_PCMTEST is not set
@@ -7567,7 +7567,7 @@ CONFIG_SND_OPL3_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
# CONFIG_SND_PCMTEST is not set
@@ -7261,7 +7261,7 @@ CONFIG_SND_OPL4_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
# CONFIG_SND_PCMTEST is not set
@@ -7276,7 +7276,7 @@ CONFIG_SND_OPL3_LIB_SEQ=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
# CONFIG_SND_PCMTEST is not set