diff mbox series

[bug#54457,1/9] gnu: Add libnetfilter-conntrack

Message ID 6bad44e1-99e7-1e72-84db-2a3f4c53b857@gmail.com
State Accepted
Headers show
Series [bug#54457,1/9] gnu: Add libnetfilter-conntrack | expand

Commit Message

fesoj000 March 21, 2022, 9:19 p.m. UTC
* gnu/packages/linux.scm (libnetfilter-conntrack): New variable.
---
  gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
  1 file changed, 28 insertions(+)

Comments

M March 23, 2022, 7:48 p.m. UTC | #1
fesoj000 schreef op ma 21-03-2022 om 22:19 [+0100]:
> +   (home-page (string-append "https://netfilter.org/projects/"
> +                             "libnetfilter_conntrack/index.html"))

You don't have to do 'string-append' here; IIUC, going beyond 80
columns is considered acceptable if it is due to long URLs.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8d9dc01839..037cb12e3f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7246,6 +7246,34 @@  (define-public nftables
  userspace queueing component and the logging subsystem.")
      (license license:gpl2)))
  
+(define-public libnetfilter-conntrack
+  (package
+   (name "libnetfilter-conntrack")
+   (version "1.0.8")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/"
+                         "libnetfilter_conntrack/files/"
+                         "libnetfilter_conntrack-"
+                         version ".tar.bz2"))
+     (sha256
+      (base32
+       "1ky1mqgnplw2h9jf0kn0a69d94jkydhbiipng9l2hdcj13h3pl8c"))))
+   (build-system gnu-build-system)
+   (supported-systems (filter target-linux? %supported-systems))
+   (native-inputs (list pkg-config))
+   (inputs (list libnfnetlink libmnl))
+   (synopsis "Library for kernel connection tracking state table.")
+   (description "libnetfilter_conntrack is a userspace library providing a
+programming interface (API) to the in-kernel connection tracking state table.
+The library libnetfilter_conntrack has been previously known as
+libnfnetlink_conntrack and libctnetlink. This library is currently used by
+conntrack-tools among many other applications.")
+   (home-page (string-append "https://netfilter.org/projects/"
+                             "libnetfilter_conntrack/index.html"))
+   (license license:gpl2+)))
+
  (define-public proot
    (package
      (name "proot")