diff mbox series

[bug#53899,01/30] gnu: Add rust-platforms-2.

Message ID 6bPdcKgTGnx-606JRTcWEWB_aFQor9SMJT4dzYr9CHX_1rOVWhLHGHsyckR6dsRPg5412jdfBtRnxyD5L0ql2BxBx-7Bvkc3lp6JK4DHhzc=@protonmail.com
State Accepted
Headers show
Series [bug#53899,01/30] gnu: Add rust-platforms-2. | expand

Commit Message

phodina Feb. 9, 2022, 4:01 p.m. UTC
Hi,

These patches add new cargo utility to audit the security of rust crates.

Maybe it could be integrated into the guix lint command to increase the auditing of rust ecosystem in GNU Guix.

However, I do see one downside as this would create coupling on rust which might be problematic e.g. on Aarch64 architecture and it would also increase the complexity and build time for guix package.

Nevertheless it can be used on it's own.

----
Petr

Comments

phodina Feb. 20, 2022, 12:55 p.m. UTC | #1
Hi Nicolas,

thanks for merging the patch set.

Btw any remarks on integration of cargo-audit with guix lint? Good/bad idea (adding Rust as dependency) ...

Also can this issue now be closed?

----
Petr
Nicolas Goaziou Feb. 22, 2022, 10:44 a.m. UTC | #2
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> These patches add new cargo utility to audit the security of rust crates.
>
> Maybe it could be integrated into the guix lint command to increase the auditing of rust ecosystem in GNU Guix.
>
> However, I do see one downside as this would create coupling on rust
> which might be problematic e.g. on Aarch64 architecture and it would
> also increase the complexity and build time for guix package.
>
> Nevertheless it can be used on it's own.

I applied the whole set minus "gnu: rust-tracing-subscriber-0.1: Add
inputs", as I couldn't make sense out of it and it didn't seem necessary
anyway.

I slightly changed a couple of synopsis and descriptions, removing words
in the former and adding Texinfo markup to the latter.

Thanks!

Regards,
diff mbox series

Patch

From 8a47e973c486e43d49f5aa1f43fd253156edf440 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sat, 5 Feb 2022 15:19:55 +0100
Subject: [PATCH 27/30] gnu: Add rust-abscissa-core-0.5.

* gnu/packages/crates-io.scm (rust-abscissa-core-0.5): New variable.

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9775adba6d..926049da03 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -141,6 +141,50 @@  (define-public rust-abomonation-0.7
 library in Rust.")
     (license license:expat)))
 
+(define-public rust-abscissa-core-0.5
+  (package
+    (name "rust-abscissa-core")
+    (version "0.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "abscissa_core" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0fmvaqzdz6qg7z42dlhvs3lf338xz0gdvdhp6xc042hjjdq6f1va"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-abscissa-derive" ,rust-abscissa-derive-0.5)
+        ("rust-backtrace" ,rust-backtrace-0.3)
+        ("rust-canonical-path" ,rust-canonical-path-2)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-color-backtrace" ,rust-color-backtrace-0.3)
+        ("rust-generational-arena" ,rust-generational-arena-0.2)
+        ("rust-gumdrop" ,rust-gumdrop-0.7)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-once-cell" ,rust-once-cell-1)
+        ("rust-regex" ,rust-regex-1)
+        ("rust-secrecy" ,rust-secrecy-0.6)
+        ("rust-semver" ,rust-semver-0.9)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-signal-hook" ,rust-signal-hook-0.1)
+        ("rust-termcolor" ,rust-termcolor-1)
+        ("rust-toml" ,rust-toml-0.5)
+        ("rust-tracing" ,rust-tracing-0.1)
+        ("rust-tracing-log" ,rust-tracing-log-0.1)
+        ("rust-tracing-subscriber" ,rust-tracing-subscriber-0.1)
+        ("rust-wait-timeout" ,rust-wait-timeout-0.2))))
+    (home-page "https://github.com/iqlusioninc/abscissa/")
+    (synopsis "Application microframework")
+    (description
+     "This package provides application microframework with support
+for command-line option parsing, configuration, error handling, logging,
+and terminal interactions.  This crate contains the framework's core
+functionality.")
+    (license license:asl2.0)))
+
 (define-public rust-abscissa-derive-0.5
   (package
     (name "rust-abscissa-derive")
-- 
2.34.0