diff mbox series

[bug#67935] gnu: containers: Add podman-compose.

Message ID 6b97b41923d5000e89b44496006530a0@lyrion.ch
State New
Headers show
Series [bug#67935] gnu: containers: Add podman-compose. | expand

Commit Message

Daniel Ziltener Dec. 20, 2023, 4:20 p.m. UTC
---
 gnu/packages/containers.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Daniel Ziltener Jan. 26, 2024, 3:31 p.m. UTC | #1
close 67935
thanks
Daniel Ziltener March 14, 2024, 10:52 a.m. UTC | #2
close 67935
thanks
diff mbox series

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index a3aa9ac1db..ccc428b3d6 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -32,6 +32,7 @@  (define-module (gnu packages containers)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix utils)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages autotools)
@@ -401,6 +402,29 @@  (define-public podman
 containers.")
     (license license:asl2.0)))
 
+(define-public podman-compose
+  (package
+   (name "podman-compose")
+   (version "1.0.6")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://github.com/containers/podman-compose.git")
+           (commit (string-append "v" version))))
+     (sha256
+      (base32
+       "11dwpifkm20vyi6r3fgmiiqc01mpm4r8l0p5gfh0bawi2gklrhsf"))))
+   (propagated-inputs
+    (list python-pyyaml
+          python-dotenv))
+   (build-system pyproject-build-system)
+   (home-page "https://github.com/containers/podman-compose")
+   (synopsis "a script to run docker-compose.yml using podman")
+   (description "An implementation of Compose Spec with Podman backend, to
+allow you to run docker-compose.yml files with Podman.")
+   (license license:gpl2)))
+
 (define-public buildah
   (package
     (name "buildah")