diff mbox series

[bug#69886] gnu: gtk: Update cairo to 1.18.0.

Message ID 6b76c31e120fda491be8ee8126cc5ae5@lyrion.ch
State New
Headers show
Series [bug#69886] gnu: gtk: Update cairo to 1.18.0. | expand

Commit Message

Daniel Ziltener March 18, 2024, 10:38 p.m. UTC
---
 gnu/packages/gtk.scm | 26 ++++++++++++--------------
 1 file changed, 12 insertions(+), 14 deletions(-)

Comments

John Kehayias March 19, 2024, 1:32 a.m. UTC | #1
Hello,

Thanks for the submission!

On Mon, Mar 18, 2024 at 11:38 PM, Daniel Ziltener wrote:

>      (native-inputs
>       `(,@(if (target-hurd?)
>               '()
>               `(("gobject-introspection" ,gobject-introspection)))
> +       ("gcc-13" ,gcc-13)
> +       ("gtk-doc" ,gtk-doc)

Note that this is a circular dependency as, gtk-doc depends on cairo currently:

--8<---------------cut here---------------start------------->8---
$ guix graph --path gtk-doc cairo
gtk-doc@1.33.2
dblatex@0.3.12
imagemagick@6.9.12-4
pango@1.50.10
cairo@1.16.0
--8<---------------cut here---------------end--------------->8---

Please see <https://issues.guix.gnu.org/69495> for my submission as
well. Since it has been a couple of weeks, I'll likely push that version
on mesa-updates for testing soon, but comments welcome.

John
Daniel Ziltener March 19, 2024, 10:23 p.m. UTC | #2
Oh, nice, I will close this here then.

close 69886
thanks
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2dcfa0edc1..9afc692e8d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -157,12 +157,11 @@  (define-public appmenu-gtk-module
      "This package provides a global menu applet for use with desktop panels
 such as mate-panel and xfce4-panel.")
     (home-page "https://gitlab.com/vala-panel-project/vala-panel-appmenu")
-    (license (list license:lgpl3))))
 
 (define-public cairo
   (package
     (name "cairo")
-    (version "1.16.0")
+    (version "1.18.0")
     (source
      (origin
        (method url-fetch)
@@ -170,17 +169,16 @@  (define-public cairo
         (string-append "https://cairographics.org/releases/cairo-"
                        version ".tar.xz"))
        (sha256
-        (base32 "0c930mk5xr2bshbdljv005j3j8zr47gqmkry3q6qgvqky6rjjysy"))
-       (patches (search-patches
-		 "cairo-CVE-2018-19876.patch"
-		 "cairo-CVE-2020-35492.patch"))))
-    (build-system glib-or-gtk-build-system)
-    (outputs '("out" "doc"))
+        (base32
+         "0r0by563s75xyzz0d0j1nmjqmdrk2x9agk7r57p3v8vqp4v0ffi4"))))
+    (build-system meson-build-system)
     (arguments
      `(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
        #:configure-flags
        (list
-        "--disable-static"
+        "-Dgtk_doc=true"
+        "-Dsymbol-lookup=disabled"
+        "-Dspectre=disabled"
         ;; XXX: To be enabled.
         ;; "--enable-gallium=yes"
         ;; "--enable-gl=yes"
@@ -189,15 +187,14 @@  (define-public cairo
         ;; "--enable-cogl=yes"
         ;; "--enable-directfb=yes"
         ;; "--enable-vg=yes"
-        "--enable-tee=yes"              ;needed for GNU IceCat
-        "--enable-xml=yes"              ;for cairo-xml support
-        (string-append "--with-html-dir="
-                       (assoc-ref %outputs "doc")
-                       "/share/gtk-doc/html"))))
+         )))
     (native-inputs
      `(,@(if (target-hurd?)
              '()
              `(("gobject-introspection" ,gobject-introspection)))
+       ("gcc-13" ,gcc-13)
+       ("gtk-doc" ,gtk-doc)
+       ("docbook-xsl" ,docbook-xsl)
        ("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)))
     (inputs
@@ -236,6 +233,7 @@  (define-public cairo
      (list
       license:lgpl2.1+
       license:mpl1.1))))
+   (license (list license:lgpl3))))
 
 (define-public cairo-sans-poppler
   ;; Variant used to break the dependency cycle between Poppler and Cairo.